LotusTalk - The Lotus Cars Community - View Single Post - What the Heck! Push in throttle, no response, just idles.
View Single Post
post #7 of (permalink) Old 10-11-2012, 07:54 AM
turbophil
Plug Whisperer
 
turbophil's Avatar
 
Join Date: Dec 2005
Location: Kansas City/ Overland Park
Posts: 6,294
you have an older 1.2 EFI as I recall... If it's a X2, it will have "X2" printed in big white lettes on the front of the case.

With the 1.2, the STOCK ECU controls all aspects of the throttle and idle speed. The EFI only controls fuel and spark/cam timing.

If throttle is not working, then you have a wiring issue going... You should be pretty familiar with that problem by now... sorry, couldn't resist


Phil: NASA 2012 and 2014 TT1 Central Champion, 2005 GG Elige, Rev400, 485+whp REV X

2011 Pearl White Evora, BOE Skunk Works 6 SPD 435WHP || 2014 Black Evora Skunk Works IPS 390WHP|| 2011 White Evora Skunk Works IPS 390WHP || 2006 CO Elise, Rev400, Steet Car

____________________________________________

www.boefab.com: We Build Champions | Products-Service-Advice


BOE ClamHinge | BOE TVS SuperCharging, The Most Powerful Track-Worthy Forced Induction | EFI Engine Management | BOE The Essential Fuel Starve Solution| BOE Lotus Tow Package| BOE New-Tech Lotus Race Engines | The Right Oil Filter for Your Lotus | Custom Lotus ECU Tuning


Pain makes man Think. Thinking makes man Wise. Wisdom makes tracking a Lotus Endurable
turbophil is offline  
 
 
For the best viewing experience please update your browser to Google Chrome