RH Headlight Out - No current - Corroded wire or SPM failure? - LotusTalk - The Lotus Cars Community
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-10-2019, 03:07 AM Thread Starter
Registered User
 
SHIFFY's Avatar
 
Join Date: Jul 2017
Location: Maryland
Posts: 15
Question RH Headlight Out - No current - Corroded wire or SPM failure?

Howdy everyone,

My RH side headlight recently went completely out. I've been troubleshooting it and I'm not getting any voltage to the plug by the headlight. I have reason to suspect it's one of the two following issues:
1. Switch Pack Module is bad
2. I have a corroded wire somewhere along the circuit

Does anyone have a wiring diagram or can you answer this? When power flows through the car, does it hit the switch pack module before it hits the fuse box or vise versa? I am getting power to the fuse.

My reason for concern is that the previous owner converted the headlights to HID's and now they are constantly on any time the car is on. I don't know if this is normal, I suspect not, so it leads me to believe there is some janky wiring going on somewhere.

Before I pull the front clam and trace the wire, I'd like to figure out the order of which modules in the current get hit.

If it is the switch pack module, where can I find one in the US in fairly speedy time?

Thanks!!
SHIFFY is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-14-2019, 12:06 PM Thread Starter
Registered User
 
SHIFFY's Avatar
 
Join Date: Jul 2017
Location: Maryland
Posts: 15
Took the dash apart and managed to get the switch pack yesterday. Ordered a new one from EliseParts.com later last week.

We'll see if that's the issue. Should be getting it in the mail tomorrow.
Attached Images
 
SHIFFY is offline  
post #3 of 3 (permalink) Old 04-15-2019, 02:24 PM Thread Starter
Registered User
 
SHIFFY's Avatar
 
Join Date: Jul 2017
Location: Maryland
Posts: 15
Got it fixed!

Ordered a new switch pack module from EliseParts.com last week, got it in the mail today and swapped the old one out for the new one!

It works like a dream!

Many thanks to EliseParts.com and your super quick shipping to the lower 48!
SHIFFY is offline  
Sponsored Links
Advertisement
 
Reply

  LotusTalk - The Lotus Cars Community > Lotus Discussions > Maintenance and Repairs.

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
*HELP* F. Turn Signal Bulb Plug/Wiring Corroded SkinnyG6954 Lighting 5 03-15-2018 09:28 AM
Front indicator bulb holder corroded and broken. What can I do? zafcee Lighting 3 04-16-2017 03:29 AM
Blinker socket corroded and disintegrated rbrand21 Maintenance and Repairs. 12 10-24-2014 01:14 PM
Elise finally out of storage, corroded brakes DarkAardvark General Discussion (Lotus related) 16 03-21-2014 07:54 PM
Oh no. No no no no no no no NOES! Sensitive folks, avert your eyes! gotapex Suspension (including wheels, tires, brakes) 21 02-28-2006 04:22 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome