LotusTalk - The Lotus Cars Community

LotusTalk - The Lotus Cars Community (https://www.lotustalk.com/forums/)
-   Northwest Region (https://www.lotustalk.com/forums/f107/)
-   -   Whidbey Island owners? (https://www.lotustalk.com/forums/f107/whidbey-island-owners-183185/)

av8or21 10-20-2013 04:37 PM

Whidbey Island owners?
 
Hi everybody, I just moved to Whidbey Island from Jacksonville, FL. I just wanted to see if there were any Lotus owners out in my area. I just bought a 2005 chrome orange Elise and I should be accepting delivery in about a month. Can't wait to meet some new people!

Lckitty 10-21-2013 10:20 AM

411 Attachment(s)
Hi and welcome to Seattle. Many of us around but I have not yet heard of anyone on whidbey. Things are quieting down a bit for winter but we're still out here. Drove mine today with her Haloween teeth.

av8or21 10-21-2013 07:39 PM

You put teeth in the grill? Nice! I could find a way to make mine a pumpkin but it's not here yet :(. Mine's going to be a daily driver, so as cold as it might be, I do have a hardtop and it'll beat riding the motorcycle in winter!

Korntera 10-23-2013 07:48 PM

Quote:

Originally Posted by Lckitty (Post 2562185)
Hi and welcome to Seattle. Many of us around but I have not yet heard of anyone on whidbey. Things are quieting down a bit for winter but we're still out here. Drove mine today with her Haloween teeth.

TTIWWOP :nanner:

Lckitty 10-24-2013 11:13 AM

411 Attachment(s)
A bit dark in the parking garage but you get the idea. It was an old for sale sign repurposed. Little zip ties to hold it on.

av8or21 10-29-2013 03:48 PM

Awesome!


All times are GMT -8. The time now is 10:46 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome