Star Motors - LotusTalk - The Lotus Cars Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 12-14-2018, 04:17 AM Thread Starter
Registered User
 
Shirp's Avatar
 
Join Date: Nov 2007
Location: Houston/College Station, Tx
Posts: 382
Star Motors

Has anyone been to Star Motors for service lately? I'm curious as to the current perception. When I first bought the car I took it to the dealer for the typical mileage checks, but preferred to do any other work myself. Then I started going to Gas Head. I did the oil line recall myself, but only on the fittings that easily came off. Thus, I still have a few original hose crimp fittings remain. My heater stopped working earlier this year and I assume it's the resistor pack. I don't want to take the clam off again and figured I can go to the dealer and have the oil line recall done and they can fix the resistor pack while the clam is off.

My Prelude rebuild.
http://www.preludepower.com/forums/s...d.php?t=256458

2008 Lotus Elise | Storm TI | Touring Pack | A/C Insulation Mod | Aluminum Carpet Buttons | JBL GTO Series Speakers | Alpine iDA_X100 | GRP Trunk Strut | darthHOLDER | re-ENFORCER | BOE TOC Oil Pan | Pro Alloy Rad | BOE Toe Links
Shirp is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-14-2018, 05:48 AM
Registered User
 
Join Date: Dec 2006
Location: West of Houston
Posts: 54
Star Motors did my oil line recall a few years ago. They did not have to take the clam off, so you will not get the deal you were hoping for. The work they did was fine and timely. I havenít been back since, so canít tell you what their service is currently like. Anything I canít do goes to Clint at Gas Head. For Houston type weather my oil was still running too cool with the two front oil coolers so I have since installed the BOE rear mounted oil cooler and have good oil temperatures now. I would skip the balance of the oil line recall and install the BOE kit instead (better oil pressure as well) and if you donít want to do the work yourself, send it to Clint.
Zink is offline  
post #3 of 4 (permalink) Old 12-14-2018, 06:48 AM
Registered User
 
kfennell's Avatar
 
Join Date: Jun 2015
Posts: 1,886
If the connectors to the oil coolers are rusted on you need to remove the clam. Do you have some saltwater?

2007 Exige S with almost every track mod...
kfennell is offline  
 
post #4 of 4 (permalink) Old 12-16-2018, 04:57 PM Thread Starter
Registered User
 
Shirp's Avatar
 
Join Date: Nov 2007
Location: Houston/College Station, Tx
Posts: 382
Good to know about the clam not coming off. I poked my head under the access panel and one of the hoses that runs horizontally along the tub had some sort of scissor looking clamp on it. I had it at Gas Head earlier this year to troubleshoot the AC so I wonder if it was used to troubleshoot and was accidentally left on the hose and that caused the heat not to blow? I removed the clamp and had heat. Not sure if it is as hot as I remember, but definitely hotter than what it was doing, which was nothing.

My Prelude rebuild.
http://www.preludepower.com/forums/s...d.php?t=256458

2008 Lotus Elise | Storm TI | Touring Pack | A/C Insulation Mod | Aluminum Carpet Buttons | JBL GTO Series Speakers | Alpine iDA_X100 | GRP Trunk Strut | darthHOLDER | re-ENFORCER | BOE TOC Oil Pan | Pro Alloy Rad | BOE Toe Links
Shirp is offline  
Sponsored Links
Advertisement
 
Reply

  LotusTalk - The Lotus Cars Community > Community > Regions > Texas Region

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome