Power lock actuator? - LotusTalk - The Lotus Cars Community
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-24-2018, 10:49 AM Thread Starter
Registered User
 
Join Date: Dec 2010
Location: Redwood City, CA
Posts: 104
Power lock actuator?

For once, the problem doesn't seem to be the CDL module. Every time I try to power lock the doors, the fuse blows. When I disconnect the driver's side lock actuator, it's fine. It also reads slightly lower resistance than the passenger-side one, though not zero. I'm guessing it's got some sort of partial short or something. Diagnosis more or less done, but that leaves two questions:

1. Anyone know if there's a non-Lotus-branded version of this thing for cheaper? It looks super generic, like it's a $10 part that's used on a half-dozen cars, but I haven't been able to find an identical-looking one from anywhere but Lotus so far.

2. Is there a trick to getting the actuator module out? I can't seem to quite get it at the right angle to get past the 90-degree bend in the metal wire that attaches it to the lock mechanism.

Last edited by Defenestrator; 02-24-2018 at 10:27 PM.
Defenestrator is offline  
Sponsored Links
Advertisement
 
Reply

  LotusTalk - The Lotus Cars Community > Lotus Discussions > Electrical

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome