Start button LED lights - Page 8 - LotusTalk - The Lotus Cars Community
Reply
 
LinkBack Thread Tools Display Modes
post #141 of 142 (permalink) Old 03-01-2017, 09:19 AM
Registered User
 
David Craig's Avatar
 
Join Date: Jun 2009
Location: Toronto
Posts: 2,931
I installed a blue LED. It worked but was much brighter than the OEM LED, perhaps about 2x as bright. It was distracting particularly for night time driving.

So I added a yellow sticker to the end of the LED and reassembled everything. Now is about the same level of brightness as the OEM LED, or perhaps a bit dimmer. Anyways now I really like it.
Attached Images
       

2009 Saffron Elise
1986 Toyota Tercel - RIP Oct 20/2012
David Craig is offline  
Sponsored Links
Advertisement
 
post #142 of 142 (permalink) Old 04-19-2018, 04:57 PM
Registered User
 
Ghia914's Avatar
 
Join Date: Sep 2017
Posts: 39
I changed my start button to red and would like to change the amber leds next to the headlight and running light switches. Does anyone know the part number or specs for these LEDs from Mouser, Jameco, Superbright, etc? I'm looking to replace D1 in the attached photo.
Attached Images
   

Last edited by Ghia914; 04-19-2018 at 05:03 PM.
Ghia914 is offline  
Sponsored Links
Advertisement
 
Reply

  LotusTalk - The Lotus Cars Community > Lotus Discussions > Electrical

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome