10 Year Anniversary. - Page 2 - LotusTalk - The Lotus Cars Community
 15Likes
Reply
 
LinkBack Thread Tools Display Modes
post #21 of 23 (permalink) Old 01-25-2019, 02:09 PM
Registered User
 
rb26dett's Avatar
 
Join Date: May 2007
Posts: 1,132
Quote:
Originally Posted by VisualEchos View Post
Wow, must be something before the cluster causing them to go out!
Yeah Lotus could never figure it out so they kept changing my cluster. Then my warranty ran out and luckily the latest cluster lasted for years and then GAWR came out with his just in time. Iíve only used his for a short period of time and then winter came.
VisualEchos likes this.
rb26dett is online now  
Sponsored Links
Advertisement
 
post #22 of 23 (permalink) Old 01-30-2019, 03:00 AM
Registered User
 
Spaz's Avatar
 
Join Date: Jun 2015
Location: Calgary Alberta Canada
Posts: 15
5 years with mine. Love this car!! I'm planning a few mods to the Exige this season. I am finishing off a 73 twin cam Europa restoration as well. Granddad to the Exige.
Spaz is offline  
post #23 of 23 (permalink) Old 01-30-2019, 07:03 AM
Registered User
 
good2go's Avatar
 
Join Date: Mar 2007
Location: So Cal
Posts: 1,964
Garage
12 yrs, 05 Elise. 80K-12K = 62K/12 = 5.16666666666... K/Year.

Modded but still NA!
good2go is offline  
Sponsored Links
Advertisement
 
Reply

  LotusTalk - The Lotus Cars Community > Lotus Discussions > Lotus Exige

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome