Weird Launch Control Tune? - LotusTalk - The Lotus Cars Community
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-09-2019, 09:53 AM Thread Starter
Registered User
 
Join Date: Sep 2019
Posts: 1
Weird Launch Control Tune?

Just bought this '08 S240 and I'm trying to figure out what's going on at low speeds (< 10mph) after pressing the traction control button (2s)

Video - https://youtu.be/-1cEJ5O7Gu8

Anyone seen this before? Is it a tune someone can identify?

The shift indicators come up and touching the throttle causes rhythmic blips. If I mash the throttle it tops out rpms at 2k.

This is not a drag car or a drift car, but it's hurting my fun by making it impossible to "peel-out" or "parallel park".
realkiran is offline  
Sponsored Links
Advertisement
 
Reply

  LotusTalk - The Lotus Cars Community > Lotus Discussions > Lotus Exige

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome