SC stopped building boost & occasional Surging Idle - LotusTalk - The Lotus Cars Community
 1Likes
  • 1 Post By Kadam
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 07-16-2017, 03:29 AM Thread Starter
Registered User
 
Join Date: Jul 2017
Posts: 18
SC stopped building boost & occasional Surging Idle

05 elise
vision function SC kit

(was driving home on a 2 hour trip. it pulled just fine initially)
all of a sudden the car will not build boost.
it also sporadically surged rpms at idle.

Eventually right before i got home it threw a p0507 idle air control system RPM higher than expected

any thoughts would be appreciated
Kadam is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-17-2017, 08:17 AM
Registered User
 
evansp60's Avatar
 
Join Date: Feb 2006
Posts: 565
Check for leaks, sounds like a hose popped somewhere

Stay Tuned.....
evansp60 is offline  
post #3 of 7 (permalink) Old 07-17-2017, 04:21 PM Thread Starter
Registered User
 
Join Date: Jul 2017
Posts: 18
update: found the problem. its fixed
http://imgur.com/a/EGQs0
forkmeupscotty likes this.

Last edited by Kadam; 07-17-2017 at 04:26 PM.
Kadam is offline  
 
post #4 of 7 (permalink) Old 07-17-2017, 07:30 PM
Registered User
 
evansp60's Avatar
 
Join Date: Feb 2006
Posts: 565
That would be a leak.....

Stay Tuned.....
evansp60 is offline  
post #5 of 7 (permalink) Old 04-06-2019, 03:47 AM
Registered User
 
Need-4-Speed's Avatar
 
Join Date: Mar 2019
Posts: 6
Hello, I’m new to the Elise car scene and noticed your post, Kadam. I too have a VF on my 05. Recently I received the P0507 check engine light and noticed higher RPMs along with a loss of pulling when hitting the throttle. I was hoping you could provide some guidance on how to remove the housing you have pictured the link below?

https://m.imgur.com/a/EGQs0

Thanks for your time,
Ryan
Need-4-Speed is offline  
post #6 of 7 (permalink) Old 04-14-2019, 04:19 PM
Registered User
 
Join Date: Apr 2016
Location: SW Ohio
Posts: 60
That housing attaches the throttle body to the inlet of the supercharger.
You will likely need to pull both the charge pipes on top to get access to the throttle body.

Sent from my SM-G950U using Tapatalk
ScottH83 is online now  
post #7 of 7 (permalink) Old 04-15-2019, 04:20 PM
Registered User
 
Need-4-Speed's Avatar
 
Join Date: Mar 2019
Posts: 6
Thanks, Scott!
Need-4-Speed is offline  
Sponsored Links
Advertisement
 
Reply

  LotusTalk - The Lotus Cars Community > Lotus Discussions > Powertrain (Engine, Transmission, etc) > Forced Induction

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome