Gutted the audio and replaced with new - LotusTalk - The Lotus Cars Community
 1Likes
  • 1 Post By tashabay716
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-16-2019, 05:04 PM Thread Starter
Registered User
 
tashabay716's Avatar
 
Join Date: Oct 2018
Location: Central Texas
Posts: 14
Gutted the audio and replaced with new

Finally got fed up with the lack of sound in the Evora 400. Read every thread on the forum regarding installing audio components and the information here was priceless.

So my set up now is:

Alpine INE W977-HD head unit
JL Audio 8 inch Subwoofer
JL Audio XD 500 3V2 driving the Sub and door speakers
JL Audio C1 door speakers
1 Case of Second Skin Pro sound dampening material

Sound dampened the doors and all around the Sub. Also sound dampened the passenger foot well and floor while I had all the carpet up. I attempted to mount 6.5 in speakers in the door for an even better sound, but after a couple of days and a bunch of torn up ABS, I decided the 5.25's would have to do. Just not enough clearance for the 6.5's and the door window mechanism. I think I could have made it work, but I would have had to dremel a lot of the door panel and the panel cover. The new system with the 5.25's will rattle the windows now anyway. Enough for me. This job was a PIA lasting about 4 days off and on. I cannot believe you have to remove a glued on Evora sill cover to remove the door sill. I never did figure out how to undo the wiring plug for the airbag system under the seat. I ended up cutting the wires and installing my own quick release plug. Some of the one use clips broke on me just like the others before me and I just used industrial grade velco to fasten back. Velco works better anyway with no rattle.
Thanks for all who posted here regarding the audio replacements.
Cheers.
dogtag114 likes this.
tashabay716 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-17-2019, 06:18 AM
Illegal Alien
 
Julian73's Avatar
 
Join Date: Oct 2011
Location: Longview, TX
Posts: 4,420
Garage
Quote:
Originally Posted by tashabay716 View Post
Finally got fed up with the lack of sound in the Evora 400. Read every thread on the forum regarding installing audio components and the information here was priceless.

So my set up now is:

Alpine INE W977-HD head unit
JL Audio 8 inch Subwoofer
JL Audio XD 500 3V2 driving the Sub and door speakers
JL Audio C1 door speakers
1 Case of Second Skin Pro sound dampening material

Sound dampened the doors and all around the Sub. Also sound dampened the passenger foot well and floor while I had all the carpet up. I attempted to mount 6.5 in speakers in the door for an even better sound, but after a couple of days and a bunch of torn up ABS, I decided the 5.25's would have to do. Just not enough clearance for the 6.5's and the door window mechanism. I think I could have made it work, but I would have had to dremel a lot of the door panel and the panel cover. The new system with the 5.25's will rattle the windows now anyway. Enough for me. This job was a PIA lasting about 4 days off and on. I cannot believe you have to remove a glued on Evora sill cover to remove the door sill. I never did figure out how to undo the wiring plug for the airbag system under the seat. I ended up cutting the wires and installing my own quick release plug. Some of the one use clips broke on me just like the others before me and I just used industrial grade velco to fasten back. Velco works better anyway with no rattle.
Thanks for all who posted here regarding the audio replacements.
Cheers.
Service Notes show the catch location of the AirBag plugs, they are designed to and all pins as unplugged so as not to cause a short/spark that can trigger the bags. Even a static charge can trigger them.

A number of write-ups on here about fitting systems and even converting to 6 1/2"

'17 Evora Sport 410 GP (No. 1 of 9) LMS alloy pan, BOE headers, SSC harness bar
'12 Evora S GP (No. 1 of 14) BOE Prototype S 430 **SOLD**
Julian73 is online now  
Sponsored Links
Advertisement
 
Reply

  LotusTalk - The Lotus Cars Community > Lotus Discussions > Lotus Evora

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome