QWKcans - Catch Cans for your Supercharged Lotus - Page 2 - LotusTalk - The Lotus Cars Community
 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #21 of 61 (permalink) Old 03-03-2010, 11:45 AM
Registered User
 
TimMullen's Avatar
 
Join Date: Jun 2003
Location: Chantilly, VA
Posts: 12,374
Quote:
Originally Posted by caboydman View Post
So catch cans for my street driven 240S is a good idea? I would do it as long as it wasn't going to cause smog issues and would benefit the supercharger/intercooler and protect the engine.
The worst that would happen at a smog check is that you would have to disconnect the hoses and put them back to the stock locations. The catch cans are just "inserted" in the middle of two existing hoses. I would really expect the likelihood of smog check problems to be very low.




Tim Mullen --- There is no such thing as Touring suspension or Touring wheels.

I love being married. It's so great to find that one person that you want to annoy for the rest of your life. - Rita Rudner


Chantilly, VA http://members.cox.net/elans4/
05 Lotus Elise - Chrome Orange - No Touring - No LSS - No Hardtop - Lotus Driving Lights - Lotus "Chin Guards" - plain and simple.
94 Miata R Package - Black
72 Lotus Elan Sprint - Colorado Orange/Cirrus White
TimMullen is offline  
Sponsored Links
Advertisement
 
post #22 of 61 (permalink) Old 03-03-2010, 10:02 PM
Registered User
 
ythart's Avatar
 
Join Date: Feb 2010
Location: Laguna Beach
Posts: 82
also an oil/coolant smell with the windows down

Please also let me know if these solve the oil smell issue with the windows down. I have an 08 also.
ythart is offline  
post #23 of 61 (permalink) Old 03-04-2010, 04:56 AM
Registered User
 
spectre's Avatar
 
Join Date: Nov 2005
Location: Ohio
Posts: 1,273
What is this oil smell? For about 1500 miles I had new car hot engine burn off smell but since nothing and I have an 08s240.
spectre is offline  
 
post #24 of 61 (permalink) Old 03-04-2010, 05:44 AM
Registered User
 
HKFEVER's Avatar
 
Join Date: Jan 2009
Location: Hong Kong
Posts: 6,170
Quote:
Originally Posted by Lew View Post
Ghussey,
Let me know if this solves the oil odor with the window down. I get the same thing on my 08 S240.
-Lew
Me too, I already have a catch can but still can't figure out where the smell comes from.

S240 Exige S with BOE FW300 + over 40 mods
HKFEVER is offline  
post #25 of 61 (permalink) Old 03-04-2010, 07:55 AM
Registered User
 
Ghussey's Avatar
 
Join Date: Aug 2006
Location: Massachusetts
Posts: 97
Quote:
Originally Posted by HKFEVER View Post
Me too, I already have a catch can but still can't figure out where the smell comes from.
You have the Catch Cans and still have the smell? Did you install the Saiku catch cans? Just wondering if oil residue leftover from before you installed the Catch Cans are causing the odor.

GHussey - Massachusetts
(SOLD: Summer 2011)2007 Exige S, Larini SC Sport Exhaust, QWKcans, Artic Silver with twin dark grey stripes down the middle, Tour Pack, Traction Control, (No Track Pack) Never Tracked, never driven in the rain by me. Gloss black powder-coated wheels. Title in hand.
Ghussey is offline  
post #26 of 61 (permalink) Old 03-04-2010, 08:25 AM
Registered User
 
ythart's Avatar
 
Join Date: Feb 2010
Location: Laguna Beach
Posts: 82
Tonight I am going to take my intercooler off and clean the oil out of it and see if the smell goes away. BTY my car is stock with only 5500 miles on it. I also can smell a little bit of coolant smell (sweet smell) above the air box. I took the air box off and checked all of the hose and found nothing. This smell is driving me crazy.
ythart is offline  
post #27 of 61 (permalink) Old 03-04-2010, 09:16 AM
Registered User
 
HKFEVER's Avatar
 
Join Date: Jan 2009
Location: Hong Kong
Posts: 6,170
Quote:
Originally Posted by Ghussey View Post
You have the Catch Cans and still have the smell? Did you install the Saiku catch cans? Just wondering if oil residue leftover from before you installed the Catch Cans are causing the odor.
When I changed the RLS pipe, oil was dripping from the left side pipe and from cooler. So I install the catch can from LTS and vent to air as LTS instructed which I know will have smell. Later on, I change the cooler to RLS and oil issue solved.

So catch can is a must for SC car.

I am sure when the car stand still I can smell oil, this is OK because I vent the can to air.

But the smell is coming from nowhere when the car is going forward fast. So I though the oil cooler up front, but checked and no leak

Now, I think it is coming from the hole at the bottom of the fire wall. I will seal it up and see what happen.

S240 Exige S with BOE FW300 + over 40 mods
HKFEVER is offline  
post #28 of 61 (permalink) Old 03-07-2010, 05:13 PM
Registered User
 
d-onion's Avatar
 
Join Date: Sep 2009
Location: Las Vegas, NV / Gilbert, AZ
Posts: 1,377
In preparation for my QWKcans to arrive tomorrow I was looking at my engine and noticed that the bolt which would hold the mount of the top of the cans is missing. I'm assuming there already should be a bolt in there?

Does anyone know what length and thread it needs to be so I can get a replacement?

2007 Ardent Red Lotus Exige S
2013 Tesla Model S
d-onion is offline  
post #29 of 61 (permalink) Old 03-07-2010, 06:25 PM
Registered User
 
holmz's Avatar
 
Join Date: Sep 2006
Location: Antipodes
Posts: 2,309
Any pictures of what the inside looks like?
How is it baffled?
holmz is offline  
post #30 of 61 (permalink) Old 03-08-2010, 07:10 AM Thread Starter
Supporting Vendor
 
shinoo's Avatar
 
Join Date: Mar 2003
Location: Murrieta, CA
Posts: 3,964
Quote:
Originally Posted by d-onion View Post
In preparation for my QWKcans to arrive tomorrow I was looking at my engine and noticed that the bolt which would hold the mount of the top of the cans is missing. I'm assuming there already should be a bolt in there?

Does anyone know what length and thread it needs to be so I can get a replacement?
Our kit comes with the hardware.

InoKinetic - Tasty Bits for Your Lotus

BlackShadow Motors - Niche Car Sales, Service & Restoration

Email or call (951)296-6762 us for advice. We will respond!
shinoo is offline  
post #31 of 61 (permalink) Old 03-08-2010, 07:11 AM Thread Starter
Supporting Vendor
 
shinoo's Avatar
 
Join Date: Mar 2003
Location: Murrieta, CA
Posts: 3,964
Quote:
Originally Posted by holmz View Post
Any pictures of what the inside looks like?
How is it baffled?
Baffling is quite simple. We are unable to release drawings of our Top Secret Baffling.

InoKinetic - Tasty Bits for Your Lotus

BlackShadow Motors - Niche Car Sales, Service & Restoration

Email or call (951)296-6762 us for advice. We will respond!
shinoo is offline  
post #32 of 61 (permalink) Old 03-08-2010, 01:25 PM
Registered User
 
d-onion's Avatar
 
Join Date: Sep 2009
Location: Las Vegas, NV / Gilbert, AZ
Posts: 1,377
Quote:
Originally Posted by shinoo View Post
Our kit comes with the hardware.
I just got it, and it is supposed to come with the hardware. Mine seems to be missing that M6 Stud which the wing nut attaches to. I did end up with 2 x M6x20mm bolts where I was only supposed to get 1.

I'm impressed by it so far. Instructions are almost foolproof. The only part that scares me is cutting the hoses .

2007 Ardent Red Lotus Exige S
2013 Tesla Model S
d-onion is offline  
post #33 of 61 (permalink) Old 03-08-2010, 01:41 PM Thread Starter
Supporting Vendor
 
shinoo's Avatar
 
Join Date: Mar 2003
Location: Murrieta, CA
Posts: 3,964
Quote:
Originally Posted by d-onion View Post
I just got it, and it is supposed to come with the hardware. Mine seems to be missing that M6 Stud which the wing nut attaches to. I did end up with 2 x M6x20mm bolts where I was only supposed to get 1.

I'm impressed by it so far. Instructions are almost foolproof. The only part that scares me is cutting the hoses .
Glad you like them. Please check the box thoroughly as the stud should be in there. Give us a call if it is missing. (951)296-6762

InoKinetic - Tasty Bits for Your Lotus

BlackShadow Motors - Niche Car Sales, Service & Restoration

Email or call (951)296-6762 us for advice. We will respond!
shinoo is offline  
post #34 of 61 (permalink) Old 03-08-2010, 03:50 PM
Registered User
 
Ghussey's Avatar
 
Join Date: Aug 2006
Location: Massachusetts
Posts: 97
Qwkcans installed on Saturday

Quote:
Originally Posted by shinoo View Post
Glad you like them. Please check the box thoroughly as the stud should be in there. Give us a call if it is missing. (951)296-6762
Here are pics of the final install of the Qwkcans from Sector111. I took my time and was a painless install. I wish I had a better knive to cut the pipes instead of my wife's butcher knife but not a terrible result. The kit was missing one M6 1.00x3mm stud to hold the top wingnut for easy-off application but Sector111 is mailing it to me. I have not driven my Exige S as of yet because the exhaust is off awaiting the arrival of my new Larini SC Sport to arrive over the next day or so.
Attached Images
   

GHussey - Massachusetts
(SOLD: Summer 2011)2007 Exige S, Larini SC Sport Exhaust, QWKcans, Artic Silver with twin dark grey stripes down the middle, Tour Pack, Traction Control, (No Track Pack) Never Tracked, never driven in the rain by me. Gloss black powder-coated wheels. Title in hand.
Ghussey is offline  
post #35 of 61 (permalink) Old 03-08-2010, 04:17 PM
Registered User
 
d-onion's Avatar
 
Join Date: Sep 2009
Location: Las Vegas, NV / Gilbert, AZ
Posts: 1,377
Guess I wasn't the only one missing the M6 stud.

I was playing with the Quick Connectors. I can get the two on the left to lock, but the two on the right won't lock. I noticed that in the pic above they all look like they are locked. Did you have any issues locking/unlocking these connectors?

2007 Ardent Red Lotus Exige S
2013 Tesla Model S
d-onion is offline  
post #36 of 61 (permalink) Old 03-08-2010, 04:42 PM
Registered User
 
Ghussey's Avatar
 
Join Date: Aug 2006
Location: Massachusetts
Posts: 97
Quote:
Originally Posted by d-onion View Post
Guess I wasn't the only one missing the M6 stud.

I was playing with the Quick Connectors. I can get the two on the left to lock, but the two on the right won't lock. I noticed that in the pic above they all look like they are locked. Did you have any issues locking/unlocking these connectors?

Yes, I had an issue with one of them. I think it's the red one on the far left. I gave up afte a while messing with it but will fiddle with it another day. Just got tired and had to do something else on Saturday. Thanks for the reminder to fix it. I was thinking it was perhaps too close to the bump on the nipple. Not sure what you would call that bump in the middle of the length of the nipples. yes, I said nipple. Maybe I'm trying to lock the connector over that bump. I didn't think but will look at it again.

GHussey - Massachusetts
(SOLD: Summer 2011)2007 Exige S, Larini SC Sport Exhaust, QWKcans, Artic Silver with twin dark grey stripes down the middle, Tour Pack, Traction Control, (No Track Pack) Never Tracked, never driven in the rain by me. Gloss black powder-coated wheels. Title in hand.
Ghussey is offline  
post #37 of 61 (permalink) Old 03-08-2010, 05:01 PM
Registered User
 
d-onion's Avatar
 
Join Date: Sep 2009
Location: Las Vegas, NV / Gilbert, AZ
Posts: 1,377
Well I just noticed that your connectors on the right go almost flush with the cans. Mine don't even get close. And as you can see the far right one has a small crack in the powder coating. Is this normal or was it damaged in shipping? It was packaged really well and no damage to the box.

The right red one doesn't go over the ridge on the nipple. I have no problems locking the 2 on the left side.
Attached Images
 
jhentr likes this.

2007 Ardent Red Lotus Exige S
2013 Tesla Model S
d-onion is offline  
post #38 of 61 (permalink) Old 03-08-2010, 05:20 PM
Registered User
 
Ghussey's Avatar
 
Join Date: Aug 2006
Location: Massachusetts
Posts: 97
Quote:
Originally Posted by d-onion View Post
Well I just noticed that your connectors on the right go almost flush with the cans. Mine don't even get close. And as you can see the far right one has a small crack in the powder coating. Is this normal or was it damaged in shipping? It was packaged really well and no damage to the box.

The right red one doesn't go over the ridge on the nipple. I have no problems locking the 2 on the left side.
The nipple on the far right is definitely bent (damaged). The crack in the powdercoat is evidence of the bent damage. The connectors should slide all the way over the hump located in the middle of each nipple. Try releasing the connector grip mechanism and then slide it all the way onto the nipple so it slides over the hump. I believe the connector should slide over the hump then be snapped shut into the locked position. The hump appears to act as a speed bump to help stop the connector from sliding off. I just tried the one connect that wouldn't lock in place on mine and gave up again. I'll try again when I have more patience.

GHussey - Massachusetts
(SOLD: Summer 2011)2007 Exige S, Larini SC Sport Exhaust, QWKcans, Artic Silver with twin dark grey stripes down the middle, Tour Pack, Traction Control, (No Track Pack) Never Tracked, never driven in the rain by me. Gloss black powder-coated wheels. Title in hand.
Ghussey is offline  
post #39 of 61 (permalink) Old 03-08-2010, 05:23 PM
Registered User
 
Ghussey's Avatar
 
Join Date: Aug 2006
Location: Massachusetts
Posts: 97
Quote:
Originally Posted by Ghussey View Post
The nipple on the far right is definitely bent (damaged). The crack in the powdercoat is evidence of the bent damage. The connectors should slide all the way over the hump located in the middle of each nipple. Try releasing the connector grip mechanism and then slide it all the way onto the nipple so it slides over the hump. I believe the connector should slide over the hump then be snapped shut into the locked position. The hump appears to act as a speed bump to help stop the connector from sliding off. I just tried the one connect that wouldn't lock in place on mine and gave up again. I'll try again when I have more patience.
Here is another view of my installed Qwkcans.
Attached Images
 

GHussey - Massachusetts
(SOLD: Summer 2011)2007 Exige S, Larini SC Sport Exhaust, QWKcans, Artic Silver with twin dark grey stripes down the middle, Tour Pack, Traction Control, (No Track Pack) Never Tracked, never driven in the rain by me. Gloss black powder-coated wheels. Title in hand.
Ghussey is offline  
post #40 of 61 (permalink) Old 03-08-2010, 06:44 PM
Registered User
 
d-onion's Avatar
 
Join Date: Sep 2009
Location: Las Vegas, NV / Gilbert, AZ
Posts: 1,377
Thanks Gerry,

The two connectors on the right definitely do not slide all the way on. I've emailed s111.

2007 Ardent Red Lotus Exige S
2013 Tesla Model S
d-onion is offline  
Sponsored Links
Advertisement
 
Reply

  LotusTalk - The Lotus Cars Community > Marketplace > Aftermarket Suppliers

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome