Long lap belt - LotusTalk - The Lotus Cars Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-18-2012, 01:45 PM Thread Starter
Nex
Registered User
 
Join Date: Mar 2011
Location: Toronto, Ontario
Posts: 165
Long lap belt

I've just finished install the schroth 4 point ASM harness on my exige. After I tighten the lap belt around my pelvis there seems to be a lot of extra harness left over. The lap belts and shoulder belts are nice and tight so fitment is good, but Im just worried about all that extra slack getting in the way of things during driving. Does anyone else have this same problem?
I've taken a picture of how the belts are when correctly tightened around my waist.

Last edited by Nex; 03-18-2012 at 01:51 PM.
Nex is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-18-2012, 05:55 PM
Mulholland>SCC
 
agirls's Avatar
 
Join Date: Mar 2008
Location: Ventura County
Posts: 2,532
I think pretty much everyone has this problem. Not entirely sure what others do, but I rolled mine up neatly and used several zip ties which works fine for me. Looks like there is something on the end of your lap belts though that I do not have.

Toys-
07 Lotus Exige S Chrome Orange
05 Ducati S4R
02 Suzuki SV650
09 Kawasaki KLX250
agirls is offline  
post #3 of 4 (permalink) Old 03-18-2012, 06:15 PM
Absolute power does what?
 
rosscarlson's Avatar
 
Join Date: Jun 2010
Location: Boulder, CO
Posts: 3,201
Well all have this issue. The cars are so small and we're so close to the belt location that this is just how it is. I just tuck them to the side when done, never been an issue for me at all. Remember these belts could be used in many other/bigger cars.

2006 Exige | Full List | BOE Rev400 (357whp) | JC Head | ProAlloy | ForceFed | BOE QS | ITG Airbox | BOE catch cans | gPan2 | Setrab | JUBU | Tillett B5s | Scroth 6pt | OMP Superquadro | interior/HVAC delete | Traqmate | Chasecam | Lift Point Kit | Ultradiscs | RBF 600 | RS14 | Vented Pistons | Penske DA 600/800lbs | V2 arms | BOELinks | ShiftEnforcer | Manly mounts | Braille | Yoko S01s | R888s | GTC-200 & Canards | RACEsills | BOE UnderAero | F1 Livery

Daily/Tow: '10 V8 Pathfinder LE
Former: '11 Jaguar XF-R | '08 Audi RS 4 | '09 Legacy Spec.B | '08 Volvo S60R | '07 Nissan 350Z
rosscarlson is offline  
 
post #4 of 4 (permalink) Old 03-18-2012, 07:02 PM Thread Starter
Nex
Registered User
 
Join Date: Mar 2011
Location: Toronto, Ontario
Posts: 165
Thanks for the replies! Glad this is normal and not due to incorrect installation.
The things at the end of the lap belts are little plastic handles that are suppose to help you grip the belt as you are tightening it.
Nex is offline  
Sponsored Links
Advertisement
 
Reply

  LotusTalk - The Lotus Cars Community > Motorsports > Safety

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome