Schroth Harness Fitting - Page 2 - LotusTalk - The Lotus Cars Community
Reply
 
LinkBack Thread Tools Display Modes
post #21 of 25 (permalink) Old 05-14-2010, 04:50 PM
Registered User
 
ma240's Avatar
 
Join Date: Mar 2010
Location: Bay Area CA
Posts: 143
I just installed the 4 point Schroths using the Sector 111 hardware kit. My car has the exige seats in it. The install causes the inner stock seat belt latch to fit more vertically and less on an angle towards the middle of the seat. When I scoot my seat forward, the latch is doing a major scrap job against the console. I called Schroth to ask about a clip-on alternative but they don't have one for the Elise. Anyone come up with a way to configure the inside harness mounting to avoid this problem?

2006 Sport Elise #47
ma240 is offline  
Sponsored Links
Advertisement
 
post #22 of 25 (permalink) Old 05-28-2010, 04:59 AM
Registered User
 
Join Date: Aug 2006
Location: London, England
Posts: 10
Quote:
Originally Posted by ma240 View Post
I just installed the 4 point Schroths using the Sector 111 hardware kit. My car has the exige seats in it. The install causes the inner stock seat belt latch to fit more vertically and less on an angle towards the middle of the seat. When I scoot my seat forward, the latch is doing a major scrap job against the console. I called Schroth to ask about a clip-on alternative but they don't have one for the Elise. Anyone come up with a way to configure the inside harness mounting to avoid this problem?
I'm now in the same position - what did you do about it?
TonyKL is offline  
post #23 of 25 (permalink) Old 06-12-2010, 12:31 PM
Registered User
 
Frank Amoroso's Avatar
 
Join Date: Mar 2006
Location: San Diego
Posts: 1,089
Quote:
Originally Posted by ma240 View Post
I just installed the 4 point Schroths using the Sector 111 hardware kit. My car has the exige seats in it. The install causes the inner stock seat belt latch to fit more vertically and less on an angle towards the middle of the seat. When I scoot my seat forward, the latch is doing a major scrap job against the console. I called Schroth to ask about a clip-on alternative but they don't have one for the Elise. Anyone come up with a way to configure the inside harness mounting to avoid this problem?

I believe you're looking to do something like this to address the situation...

https://www.lotustalk.com/forums/f92/...harness-15567/



If so, I have two sets of machined mounting hardware lying around here somewhere if you're interested. Worked great for me.

Frank Amoroso
Fun with cars
Frank Amoroso is offline  
 
post #24 of 25 (permalink) Old 06-12-2010, 05:01 PM
Registered User
 
Pandora's Avatar
 
Join Date: Aug 2009
Location: Indiana
Posts: 361
Frank, PM sent!

'17 Lamborghini Huracan Spyder, Grigio Titans (matte grey)

Previous: '07 Exige S, Laser Blue
'13 McLaren MP4-12C, Azure Blue
'16 Lamborghini Aventador Roadster, Nero Pegaso (black)
Pandora is offline  
post #25 of 25 (permalink) Old 06-14-2010, 12:42 AM
Registered User
 
Join Date: Aug 2006
Location: London, England
Posts: 10
I had to remove my handbrake leather cover as that was preventing me moving the seat forward. With a little playing I managed to get everything fitted ok.
TonyKL is offline  
Sponsored Links
Advertisement
 
Reply

  LotusTalk - The Lotus Cars Community > Motorsports > Safety

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome