I had to watch a F%$*@*% commercial to reset my password! - Page 3 - LotusTalk - The Lotus Cars Community
 14Likes
Reply
 
LinkBack Thread Tools Display Modes
post #41 of 46 (permalink) Old 09-20-2016, 11:15 AM
Registered User
 
Lancia's Avatar
 
Join Date: Dec 2006
Posts: 2,376
Works now, if this is the right page.
Forum Threads - LotusTalk - The Lotus Cars Community

Top Section
Hey guys,

We would love to hear your feedback and any suggestions you may have for our new LotusTalk.com store.

Let us know if there is a color option you would like added or a particular merchandise item you would like to see in the store. Have you had a chance to buy an item from our store? Then we want to hear what you think about the merchandise you bought.

If you would like to provide feedback/suggestions please post in here Forum Threads

~ Community Support

'Forum or Feedback' was the link I was trying.
Did nothing before.
I use adblock.
No popups lately.
Lancia is offline  
Sponsored Links
Advertisement
 
post #42 of 46 (permalink) Old 11-23-2016, 11:23 AM
Registered User
 
Join Date: Nov 2016
Posts: 23
I got very strange situation. Now I can only log in from 1 computer (from where I reset the password, and saved it). Since the password so complicate, I don't remember & I can't log in from another computer. I reset it again. Entered my email. Answered the "Human verification question" right, and waited for the email reset to come. But it never came, so I did it again, and again. None. I contacted admin, admin contacted me after a day, said sent me the email reset instruction. None. I got the email from admin though. Checked junk and deleted mail, none.

Couldn't get log in from work, I just made another user name. It's me, my old user name: Harix.
A1Harry is offline  
post #43 of 46 (permalink) Old 11-23-2016, 11:46 AM
A1 Automotive & Smog
 
Harix's Avatar
 
Join Date: Feb 2009
Location: San Gabriel, CA
Posts: 836
Got it. Thanks so much Jeff!
Harix is online now  
 
post #44 of 46 (permalink) Old 11-24-2016, 06:44 AM
Administrator
 
Join Date: Jul 2008
Location: Toronto, Canada
Posts: 1,313
Quote:
Originally Posted by A1Harry View Post
I got very strange situation. Now I can only log in from 1 computer (from where I reset the password, and saved it). Since the password so complicate, I don't remember & I can't log in from another computer. I reset it again. Entered my email. Answered the "Human verification question" right, and waited for the email reset to come. But it never came, so I did it again, and again. None. I contacted admin, admin contacted me after a day, said sent me the email reset instruction. None. I got the email from admin though. Checked junk and deleted mail, none.

Couldn't get log in from work, I just made another user name. It's me, my old user name: Harix.
Hey Harix,

if you save it on one computer and it's saved on the browser, you can go into the password manager settings in your browser and see what your password was. If that doesn't work, send me a PM and I'll help you reset your password.

Lee
Administrator is offline  
post #45 of 46 (permalink) Old 03-07-2017, 06:14 AM
eZg
Registered User
 
Join Date: Jan 2014
Location: Deep South
Posts: 319
I have tried your suggestions.......but the delay I experience even when just scrolling through threads.....makes this site unusable.

Love the content and people here but I simply spend too much time waiting for the website to "Catch up"?!?

I'm a member of multiple car forums and this is the only one I have ever experienced this issue with since about the year 2000.
eZg is offline  
post #46 of 46 (permalink) Old 03-07-2017, 11:43 AM
Such moderate
 
Doge's Avatar
 
Join Date: Sep 2010
Location: USA
Posts: 6,706
Garage
Quote:
Originally Posted by eZg View Post
I have tried your suggestions.......but the delay I experience even when just scrolling through threads.....makes this site unusable.

Love the content and people here but I simply spend too much time waiting for the website to "Catch up"?!?

I'm a member of multiple car forums and this is the only one I have ever experienced this issue with since about the year 2000.
What browser? We have had a few users say this, but it ended up being on their end.

Alot of people use chrome with adblock and it works very well.
Doge is offline  
Sponsored Links
Advertisement
 
Reply

  LotusTalk - The Lotus Cars Community > Community > Lotus Talk Forum Feedback and Site Issues

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome