It's 2016, why don't you have basic encryption? - LotusTalk - The Lotus Cars Community
 1Likes
  • 1 Post By philethier
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 09-13-2016, 07:36 PM Thread Starter
Registered User
 
Join Date: Mar 2015
Location: Morton, IL
Posts: 353
Thumbs down It's 2016, why don't you have basic encryption?

So an eCommerce site that doesn't use encryption (TLS) to secure our Personally Identifiable Information (PII) during checkout. Awesome, sign me up.

I guess your vendor, tshirtdrop, took the "No Experience Needed" selling point of WIX to heart when creating their website, since they clearly have no experience with eCommerce.

Is your third party vendor a group a high school kids in their parents basement?

Seriously, a TLS (encryption) certificate costs $50/year and takes all of 10 minutes to install on a web server.

Also, your privacy policy suspiciously doesn't even mention standard sections covering how sensitive data is protected and if/to what extent the collected data is shared.
mwehnes is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 09-14-2016, 06:13 AM
Registered User
 
philethier's Avatar
 
Join Date: Jul 2008
Location: Minnesota
Posts: 2,927
Quote:
Originally Posted by mwehnes View Post
So an eCommerce site that doesn't use encryption (TLS) to secure our Personally Identifiable Information (PII) during checkout. Awesome, sign me up.

I guess your vendor, tshirtdrop, took the "No Experience Needed" selling point of WIX to heart when creating their website, since they clearly have no experience with eCommerce.

Is your third party vendor a group a high school kids in their parents basement?

Seriously, a TLS (encryption) certificate costs $50/year and takes all of 10 minutes to install on a web server.

Also, your privacy policy suspiciously doesn't even mention standard sections covering how sensitive data is protected and if/to what extent the collected data is shared.
I think I hear somebody volunteering to help with technical issues on the webliste.
JWA likes this.

Phil Ethier Minnesota USA
1973 Triumph Stag LE22439UBW "uncle jack", Sapphire Blue
2004 Suburban 8.1, Sport Red
2005 Lotus Elise, Bordeaux Red Pearl
2017 Ford Fusion (wife had to stop driving manual due to shoulder problem), Oxford White.
2006 Gulf Stream Conquest Super C
http://www.mnautox.com
philethier is offline  
post #3 of 4 (permalink) Old 09-15-2016, 06:21 AM
Registered User
 
Join Date: Sep 2016
Location: in Huachuca Mts, ~80 miles SE of Tucson, using wonderfully twisty SR83
Posts: 14
Garage
I'm not sure which is needed more: basic encryption or basic help. I vaguely remember seeing a link to something like "new user help", but it disappeared before i selected it, and i've not seen it since. I am sure that i probably send my pw to lotustalk in cleartext, but i'm not terribly concerned about that, as long as i'm aware of it. I am also sure that i will not be buying anything from this site until the "s" appears. In the meantime, HOW CAN I GET SOME BASIC USER HELP!???!? Happy lateral acceleration (i think that's redone-dundant).
dondemaret is offline  
 
post #4 of 4 (permalink) Old 09-15-2016, 06:40 AM
Registered User
 
Join Date: Sep 2016
Location: in Huachuca Mts, ~80 miles SE of Tucson, using wonderfully twisty SR83
Posts: 14
Garage
In fact, i think it's just as well to use this as my help thread. Here are a few questions i have wrt posting:
1. When i go to my GARAGE, i see 1 pic of my elise, even tho i have uploaded at least 6 (the number is nebulous because i've uploaded the same 6 files dozens of times, but i don't know how to know--or even how to guess. I did notice a "HELP" at the bottom of "My Garage" links, so i clicked it and got: "No help was found for dto_garage (1.4.11, user)". Is there perhaps somewhere else to look? Should i just Google "How to get user help in LotusTalk"? Of course, the fact that lotustalk is not secure might make that unwise. At least we can celebrate the excellent (i believe) security of the lotus itself. So, does anyone know where i can get some help uploading files to MyGarage? (Right now, all i can see is a *single* file representing my lotus, and it asks if i want to add another vehicle. I would like to add my s2000, but i think i'll wait til i get some better pix. I don't see a way to add pix to the lotus in MyGarage. I have tried several times to add 6, but i don't see how to get to them from where i am ("Want to add another vehicle?" Yes i do, but not now. Where/how do i see that the pix i have already tried to upload have in fact become visible to other users? Please Tell Me, lotustalk!
dondemaret is offline  
Sponsored Links
Advertisement
 
Reply

  LotusTalk - The Lotus Cars Community > Community > Lotus Talk Forum Feedback and Site Issues

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome