Worst website award - LotusTalk - The Lotus Cars Community
 4Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 25 (permalink) Old 10-06-2016, 07:25 AM Thread Starter
Registered User
 
Join Date: Jul 2015
Location: Carlsbad ca
Posts: 224
Worst website award

Wow why does this website suck so bad? I think it's worse than the old dial up sites I used 20 years ago. Why is it so slow, why does it constantly reload, why do I have to try multiple times just to make a post? It makes me want to throw my coffee and smash my iPad! I have to go to the euro lotus sites just to read posts in peace. I'm a member to multiple forums, websites, webpages etc. this one gets the award for the worst by far.
Sorry for the rant, maybe I need to give up the coffee. Everybody have a good drive today.
Attached Images
 
Lckitty likes this.
Ob917 is offline  
Sponsored Links
Advertisement
 
post #2 of 25 (permalink) Old 10-06-2016, 07:27 AM
Recreational Mechanic
 
Nickshu's Avatar
 
Join Date: Sep 2015
Location: Northern Colorado, USA
Posts: 833
Garage
Must be on your end. It runs great for me all the time.

Nick____________
2005 Elise - Chrome Orange (SOLD)
2004 Porsche 911 GT3
Nickshu is offline  
post #3 of 25 (permalink) Old 10-06-2016, 07:31 AM Thread Starter
Registered User
 
Join Date: Jul 2015
Location: Carlsbad ca
Posts: 224
Quote:
Originally Posted by Nickshu View Post
Must be on your end. It runs great for me all the time.
That would make sense but I don't think so, I have no issues with any other sites. Just replying to you was a pain.
Ob917 is offline  
 
post #4 of 25 (permalink) Old 10-06-2016, 07:33 AM
Recreational Mechanic
 
Nickshu's Avatar
 
Join Date: Sep 2015
Location: Northern Colorado, USA
Posts: 833
Garage
Huh. It runs fine on my computer, ipad and phone. I do use Tapatalk on my phone to access it b/c it's easier to see.

Try running Speedtest.net on your connection.

Nick____________
2005 Elise - Chrome Orange (SOLD)
2004 Porsche 911 GT3
Nickshu is offline  
post #5 of 25 (permalink) Old 10-06-2016, 08:27 AM
Registered User
 
Tazicon's Avatar
 
Join Date: Jul 2014
Location: Las Vegas
Posts: 1,063
Garage
Runs like crap for me too. I can't hardly type............ Its happens at work, at home not sure on the phone but TapTalk probably helps.

FYILifetime memebers wn't have he issues ey don'have alls from what I understanmd


Ok that above is what it looks like when I type, and I don't type fast. I am a two finger pecker


FYI: Lifetime members won't have the issues as they don't have all the ads from what I understand.

Maybe its premium members

Had to go back and fix al this, takes a long time, gets frustrating ....................


Edit: fix all this, flippin site
Lckitty likes this.
Tazicon is offline  
post #6 of 25 (permalink) Old 10-06-2016, 08:56 AM
He's on fire!
 
jds62f's Avatar
 
Join Date: Jun 2006
Posts: 3,035
I don't have issues on any device and I don't have a premium membership, an ad blocker, or any high end machines.

"Give a man a match, and he'll be warm for a minute, but set him on fire, and he'll be warm for the rest of his life."
jds62f is offline  
post #7 of 25 (permalink) Old 10-06-2016, 09:24 AM
CMP
Registered User
 
CMP's Avatar
 
Join Date: Jan 2012
Posts: 768
fine over here. i'd start with your ipad and work backwards.

Oh snap! I'm on fire!
CMP is offline  
post #8 of 25 (permalink) Old 10-06-2016, 09:35 AM
Registered User
 
AirCavHokie's Avatar
 
Join Date: Sep 2008
Location: NoVa
Posts: 82
FWIW, no issues using Chrome with AdBlockPlus on a MacBook Air.

RIP: 2005 Elise, metallic green/biscuit touring
AirCavHokie is offline  
post #9 of 25 (permalink) Old 10-06-2016, 09:53 AM
Registered User
 
XHILR8N!'s Avatar
 
Join Date: Dec 2006
Location: 2 laps down
Posts: 6,690
Garage
Works fine for me with Safari and Firefox.

Nice picture. Worthy of the upcoming calendar IMHO.

Anyone can make something complicated. It takes genius to make it simple. Einstein.
2011 Evora S Racing Heritage Edition (#3 of 4) (Now with alexsharkeyross)
2005 Elise LRG, Trim Shop interior, full cage, Cup wheels, BWR 'charger lives!
1974 Lotus Europa Special 3841R in JPS livery
2007 Toyota Tundra (about 10 cup holders), traded for 2015 Tundra TRD PRO
2007 Audi S4 DTM (RIP) 1980 Rover SD1 (new home) 2015 Honda Civic Si
2016 370Z Nismo
2013 Bentley Continental GT Speed
XHILR8N! is offline  
post #10 of 25 (permalink) Old 10-06-2016, 10:09 AM Thread Starter
Registered User
 
Join Date: Jul 2015
Location: Carlsbad ca
Posts: 224
I'm glad I'm not the only person having issues.
Ob917 is offline  
post #11 of 25 (permalink) Old 10-06-2016, 11:09 AM
shay2nak
 
shay2nak's Avatar
 
Join Date: Dec 2003
Location: Calipornia
Posts: 24,798
switch to "classic view". I use this always.
MotoGeek likes this.

** save ~10 lbs gain 1 hp ** EQ: Y=(190*X) / (1984-X) where Y is (HP) and X is (lbs)

'07 Lotus Exige S310


WTC 2
shay2nak is online now  
post #12 of 25 (permalink) Old 10-06-2016, 11:18 AM
Such moderate
 
Doge's Avatar
 
Join Date: Sep 2010
Location: USA
Posts: 6,706
Garage
Quote:
Originally Posted by Nickshu View Post
Must be on your end. It runs great for me all the time.
Same here.

Quote:
Originally Posted by shay2nak View Post
switch to "classic view". I use this always.
OP, maybe try this.
Formulabob likes this.
Doge is offline  
post #13 of 25 (permalink) Old 10-06-2016, 11:45 AM Thread Starter
Registered User
 
Join Date: Jul 2015
Location: Carlsbad ca
Posts: 224
Thanks for the advice guys, I'll try classic.
Ob917 is offline  
post #14 of 25 (permalink) Old 10-06-2016, 11:59 AM
Registered User
 
TedR's Avatar
 
Join Date: Jun 2005
Location: Oregon
Posts: 820
I concur. Try classic and add an ad blocker as well.
TedR is offline  
post #15 of 25 (permalink) Old 10-06-2016, 12:18 PM
Saffron Yellow is Lighter
 
XtinctElise's Avatar
 
Join Date: Jan 2006
Location: Omaha, NE
Posts: 1,222
Quote:
Originally Posted by Tazicon View Post
I am a two finger pecker


Try a PC.

'05 Lotus Elise - Saffron Yellow | Sport Pack | Touring Pack | REV400 - 5.6 lbs/hp | ACT HDSS Clutch | DMC Header | Sport Cat | Larini SE Exhaust | Monolites/R888R | BWR Double-Adjustable Shocks | shiftR111/LETSLA/SSC Cables | Shorai Lithium-Iron Battery
XtinctElise is online now  
post #16 of 25 (permalink) Old 10-06-2016, 12:53 PM Thread Starter
Registered User
 
Join Date: Jul 2015
Location: Carlsbad ca
Posts: 224
Talking

Classic is much better, you guys are awesome!
Ob917 is offline  
post #17 of 25 (permalink) Old 10-06-2016, 02:12 PM
Registered User
 
Tazicon's Avatar
 
Join Date: Jul 2014
Location: Las Vegas
Posts: 1,063
Garage
Dang all this time being frustrated and a quick switch and everything works great............thanks for the heads up!
Tazicon is offline  
post #18 of 25 (permalink) Old 10-06-2016, 08:20 PM
Registered User
 
Parko's Avatar
 
Join Date: Aug 2015
Location: Arkansas
Posts: 339
Garage
I never use an iPad for it, but this site is the reason I installed an ad blocker. I had a terrible time at first--ridiculous with the ads! It got better after I paid for the membership, but still not cured. Several posters told me it was my computer, that I had malware, surfed for too much porn, etc.

One of the admins pointed something out though, if you browse without logging in, the ads seems to be WAY worse (that's not how he phrased it lol). I started logging in and the pages load much faster, even without a pop up blocker. The memory usage quit creeping up (for instance, leaving the browser open over night would result in a molasses computer in the morning, with the browser eating up tons of RAM, but only if I left a Lotustalk tab open).

So, make sure you are logging in! I'd wager that many set it to automatically login and forget what the site is like without logging in.

Last edited by Parko; 10-08-2016 at 10:16 AM. Reason: grammar and corrections
Parko is offline  
post #19 of 25 (permalink) Old 10-07-2016, 05:21 AM
Registered User
 
EricH's Avatar
 
Join Date: Nov 2007
Location: Dallas, Texas
Posts: 1,326
On a PC as a guest there are too many ads and sh*t flying across screen even with blockers. When I am logged in it is ok.

On an iPhone with Safari the normal (Enhanced Mobile view) view is absolutely useless... I don't know how anyone can read anything.. as you scroll things reorganize and jump up and down so you have to scroll back up to get back to a thread you saw then it seems to jump down again... it is crazy worthless. So, every time I use my phone I have to EXIT Enhanced Mobile view. Classic view works fine, as does the full version and my favorite which is full version classic that makes it look more like it does with a PC. Anyway, swapping all these views is annoying. Perhaps that is what TapTalk helps with but I don't want to install it on my phone.


Click links to see my 2008 Lotus Exige-S 240 , '99 M3, 505rwhp '89 Mustang ( sold) , '05 WRX STI ( sold) homepages or here for my spin compilations (ispunuwin & ispinuwin2!)!
EricH is offline  
post #20 of 25 (permalink) Old 10-07-2016, 06:21 AM Thread Starter
Registered User
 
Join Date: Jul 2015
Location: Carlsbad ca
Posts: 224
I did figure out a while back that if you aren't logged in it's even worse. Mobile view on a phone is useless. The advice to go to classic view is the ticket.
Ob917 is offline  
Sponsored Links
Advertisement
 
Reply

  LotusTalk - The Lotus Cars Community > Community > Lotus Talk Forum Feedback and Site Issues

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome