Youtube https - LotusTalk - The Lotus Cars Community
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 03-03-2015, 03:56 PM Thread Starter
Registered User
 
forkmeupscotty's Avatar
 
Join Date: Nov 2009
Location: Mountain View
Posts: 2,074
Youtube https

It's been a while since youtube started using https as default, and that seems to have broken(not really) the forum software's youtube plugin.

So anything that starts with https turns into a link stead of being parsed and getting embedded like the old http.

I don't think it'll be hard to tweak/update at all.

2001 2JZ-GE
2008 N54B30
2008 2ZZ-GZE
2015 N63B44O1

http://www.youtube.com/forkmeupscotty
forkmeupscotty is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 03-03-2015, 04:46 PM
RBH
Registered User
 
RBH's Avatar
 
Join Date: Oct 2010
Location: Northern VA
Posts: 2,190
Good point. Perhaps it is time to do a proper update/upgrade.

Do it once. Do it right.
RBH is offline  
post #3 of 11 (permalink) Old 03-04-2015, 08:04 AM
Such moderate
 
Doge's Avatar
 
Join Date: Sep 2010
Location: USA
Posts: 6,706
Garage
I'll have this looked into.
Doge is offline  
 
post #4 of 11 (permalink) Old 03-04-2015, 09:47 AM
Registered User
 
Join Date: Apr 2008
Location: Florida
Posts: 3,637
If somebody wants to post a video in the mean time, simply remove the "s" from the https and the video will automatically embed.

Test
qu1Z is offline  
post #5 of 11 (permalink) Old 03-05-2015, 02:40 AM Thread Starter
Registered User
 
forkmeupscotty's Avatar
 
Join Date: Nov 2009
Location: Mountain View
Posts: 2,074
Also, youtube likes to shorten their URLs as http://youtu.be/[insert video id here]
It shouldn't be too hard for the forum to parse that, either.

So, in summary, the forum software needs be able to handle:
http://www.youtube.com/
https://www.youtube.com/
http://youtu.be/

2001 2JZ-GE
2008 N54B30
2008 2ZZ-GZE
2015 N63B44O1

http://www.youtube.com/forkmeupscotty
forkmeupscotty is offline  
post #6 of 11 (permalink) Old 03-05-2015, 06:59 AM
Administrator
 
Join Date: Jul 2008
Location: Toronto, Canada
Posts: 1,313
should be good now....


test


http://youtu.be/hySs3drtK0M


Administrator is offline  
post #7 of 11 (permalink) Old 03-05-2015, 09:16 PM Thread Starter
Registered User
 
forkmeupscotty's Avatar
 
Join Date: Nov 2009
Location: Mountain View
Posts: 2,074
Very close, but not quite...

testing again for youtu.be link...
http://youtu.be/dQw4w9WgXcQ

2001 2JZ-GE
2008 N54B30
2008 2ZZ-GZE
2015 N63B44O1

http://www.youtube.com/forkmeupscotty
forkmeupscotty is offline  
post #8 of 11 (permalink) Old 03-06-2015, 07:59 AM
Administrator
 
Join Date: Jul 2008
Location: Toronto, Canada
Posts: 1,313
youtu.be is a mobile link and it's something that the forum can't support as is. We may be able to convert the youtu.be variable to youtube.com but there's no guarantee that it'll work.

~KM, community support
Administrator is offline  
post #9 of 11 (permalink) Old 03-06-2015, 09:57 AM
Such moderate
 
Doge's Avatar
 
Join Date: Sep 2010
Location: USA
Posts: 6,706
Garage
Quote:
Originally Posted by forkmeupscotty View Post
Very close, but not quite...

testing again for youtu.be link...
http://youtu.be/dQw4w9WgXcQ
Usually when I see links like this, I'll go into the post and edit it to a normal link for the OP so it will hotlink.
Doge is offline  
post #10 of 11 (permalink) Old 03-06-2015, 05:20 PM Thread Starter
Registered User
 
forkmeupscotty's Avatar
 
Join Date: Nov 2009
Location: Mountain View
Posts: 2,074
Awful nice, very kind, much moderate, doge. It's not much of a trouble, but things that should be able to be automated should be automated...

http://youtu.be/ links seem like they're default sharing link when you press the 'share' button from youtube. The link I posted above was done on a PC through chrome.

It should be noted the variable that follows after http://youtu.be/ is the unique ID for the video. So all that needs to be done is parse/truncate/replace http://youtu.be with http://www.youtube.com/watch?v=, or rather, https://www.youtube.com/watch?v=


ex)
http://youtu.be/2Z4m4lnjxkY

I think a simple hack could work if it can be done.

2001 2JZ-GE
2008 N54B30
2008 2ZZ-GZE
2015 N63B44O1

http://www.youtube.com/forkmeupscotty
forkmeupscotty is offline  
post #11 of 11 (permalink) Old 03-09-2015, 09:18 AM
Administrator
 
Join Date: Jul 2008
Location: Toronto, Canada
Posts: 1,313
The replacement request has been sent to the tech team.

~KM, community support
Administrator is offline  
Sponsored Links
Advertisement
 
Reply

  LotusTalk - The Lotus Cars Community > Community > Lotus Talk Forum Feedback and Site Issues

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome