LotusTalk - The Lotus Cars Community

LotusTalk - The Lotus Cars Community (https://www.lotustalk.com/forums/)
-   Powertrain (Engine, Transmission, etc) (https://www.lotustalk.com/forums/f25/)
-   -   is the Toyota 2GRFE = Lotus 2GRFE ? need to perform an engine replacement ASAP... (https://www.lotustalk.com/forums/f25/toyota-2grfe-lotus-2grfe-need-perform-engine-replacement-asap-437553/)

kaioser 12-22-2017 06:55 AM

is the Toyota 2GRFE = Lotus 2GRFE ? need to perform an engine replacement ASAP...
 
2013 Lotus Evora S engine replacement will any standard 2GRFE work to swap old engine?


2013 Lotus Evora S IPS needs engine replacement, supercharger and other ancillaries are fine;

will any 2GRFE work? or is it specific model years of the 2GRFE,


do I only need swap or provide larger injectors?

assuming the Evora has larger ones or are there ANY other spec differences or deviations from Toyo 2GRFE.

Please only respond if you have worked an engine swap or rebuild and know for a fact if its a simple swap or otherwise.

If there is a document that outlines any differences between the toyo 2grfe and the Lotus 2grfe , send me the link.

phaphaphooey 12-22-2017 06:40 PM

Search. This has been covered before.

jlobo941 12-28-2017 07:30 AM

Quote:

Originally Posted by phaphaphooey (Post 5661433)
Search. This has been covered before.

Do you, or do you not know the answer?

CRG53 12-28-2017 12:23 PM

From what I have read, the answer is no. :frown2:

GatorMS_Service 12-29-2017 08:24 AM

The engine repair manual Lotus gives us is from a 2007 RAV4. I dont know much beyond that, sorry. Hope this helps.

Thanks,
T.J.


All times are GMT -8. The time now is 04:30 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome