Airbag light help! - LotusTalk - The Lotus Cars Community
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-19-2017, 08:27 PM Thread Starter
Registered User
 
Join Date: Nov 2015
Posts: 152
Airbag light help!

Hello everyone I have a 05 lotus that was crashed in the rear and the airbags didnt deploy in order for me to pass chp inspection in order to register the car in california i have to have the idiot light for the airbag lit when I turn on the ignition. But my light does not turn on at all even when just the ignition is on and car isn't on. Any ideas where I should start with this
Jos3torr3s is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-21-2017, 09:12 AM Thread Starter
Registered User
 
Join Date: Nov 2015
Posts: 152
Anybody?
Jos3torr3s is offline  
post #3 of 5 (permalink) Old 08-21-2017, 10:13 AM
Registered User
 
cyow5's Avatar
 
Join Date: Mar 2013
Location: NoVa
Posts: 3,873
Your SRS control unit is probably not receiving power either because of bad wiring or a disconnected connector. I'd start at the module, unplug it if it is not already, and then work your way back with a voltmeter.

"Lots Of Trouble; Usually Serious"
cyow5 is offline  
 
post #4 of 5 (permalink) Old 08-21-2017, 11:11 AM Thread Starter
Registered User
 
Join Date: Nov 2015
Posts: 152
Quote:
Originally Posted by cyow5 View Post
Your SRS control unit is probably not receiving power either because of bad wiring or a disconnected connector. I'd start at the module, unplug it if it is not already, and then work your way back with a voltmeter.
Where is the module
Jos3torr3s is offline  
post #5 of 5 (permalink) Old 08-21-2017, 11:55 AM
Registered User
 
cyow5's Avatar
 
Join Date: Mar 2013
Location: NoVa
Posts: 3,873
The service manual says it is mounted to the scuttle beam (the horizontal extrusion that is the above your shins when driving), but I don't see where it says specifically where.

"Lots Of Trouble; Usually Serious"
cyow5 is offline  
Sponsored Links
Advertisement
 
Reply

  LotusTalk - The Lotus Cars Community > Lotus Discussions > Lotus Elise

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome