MWR Stage 3 Cams - Sound difference? - LotusTalk - The Lotus Cars Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-07-2018, 09:19 AM Thread Starter
Registered User
 
Join Date: Mar 2015
Posts: 4
MWR Stage 3 Cams - Sound difference?

hi there ... just building my engine up for the full BOE REV400 and installed the MWR Stage 3 Cams, JRC Head and Mahle Pistons. BOE tuned ecu and have the expected rough idle but i'm told the overall sound should still be close to stock - but it's not - to me and my mechanic it just sounds like a big cam (throaty and a bit lumpy). There's no apparent misfire or codes coming but it sure doesn't sound anything close to stock either - which again, i'm being told it should sound pretty much like (by BOE).

Just curious what other's experience was and if this is normal or we have some sort of issue??
100mph is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-09-2018, 01:39 PM
Registered User
 
Spirit_R's Avatar
 
Join Date: Mar 2014
Location: Wisconsin
Posts: 171
Garage
I would think by the very nature of it, its going to sound different and run a bit more rough at idle. Maybe try asking a shop that would know like inokinetic or monkeywrench?

'05 Lotus Elise Touring Hardtop-REV400+Track mods
'94 Mazda RX-7 Twin Turbo-Reliability mods
'09 Dodge Viper VOIX edition-no mods
Spirit_R is offline  
post #3 of 4 (permalink) Old 06-09-2018, 04:31 PM
Registered User
 
Mobius0034's Avatar
 
Join Date: Apr 2016
Posts: 145
The one rev 400 kit I heard with a stage 3 cam def sounded like it had a cam... no where near stock idle
Mobius0034 is offline  
 
post #4 of 4 (permalink) Old 06-10-2018, 12:20 PM Thread Starter
Registered User
 
Join Date: Mar 2015
Posts: 4
Thank you!

We're chasing the issue but it seems to be in the JRC head. They've done a compression test and all cylinders are the same. Going to do a leak down test tomorrow but seems to be something with the head and/or cam. It's now throwing misfire codes so we know there's something wrong somewhere!

I'm sure it will sound different but i don't think as dramatic as this ...
- not that it sounds bad lol, just not right to me
100mph is offline  
Sponsored Links
Advertisement
 
Reply

  LotusTalk - The Lotus Cars Community > Lotus Discussions > Lotus Elise

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome