New-to-me Elise. Questions under the front clam - LotusTalk - The Lotus Cars Community
 4Likes
  • 1 Post By glb
  • 3 Post By E.Murray
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 05-23-2019, 06:14 AM Thread Starter
Registered User
 
E.Murray's Avatar
 
Join Date: Apr 2019
Location: SW MO
Posts: 94
New-to-me Elise. Questions under the front clam

I just got a 2005 Elise delivered. I have zero history, so before a first drive, I'm doing all the maintenance things on it. I ran into a few questions when looking under the front clam.
  • First, there are plastic fittings going into the brake master cylinder. Both are broke (meaning the reservoir is empty). Glad I didn't try to drive it... When I look up master cylinders, the pictures don't show these plastic pieces. But I can't find them separately, either. Where can I get them? I'm dead in the water without this.
  • Second, there is a box under there that is broken/melted (see attached picture). What is this?
  • Finally, when looking in front of the tire in the passenger's side (right) wheel well, I can see an AC line. It looks like there is a plug or something in it which might be broken. What is this? (see attached)

It looks like I'm also going to need the torx-style tool to pull the wheels off since the car didn't come with a tool kit. If anybody has ideas on where to buy one, I'm all ears.
Thanks!
Attached Images
   
E.Murray is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 05-23-2019, 06:26 AM
Registered User
 
kfennell's Avatar
 
Join Date: Jun 2015
Posts: 2,043
1. Are the lines broken or just not plugged in, they actually come in and out of the reservoir pretty easy. If they are broke I think you're going to have to get a new reservoir if you're in a hurry but id doesn't NEED to be OEM.
2. That looks like a resistor pack box that has been relocated to that area so when it fails in the future its not a 6 hour job to change it.
3. That is a AC service port, that has been bent for sure, but if it's not leaking then it is what it is.

Someone will come on here with the tool available for sale They are in the $20s normally. I just use studs and nuts now.

2007 Exige S with almost every track mod...
kfennell is online now  
post #3 of 13 (permalink) Old 05-23-2019, 07:36 AM
glb
Registered User
 
glb's Avatar
 
Join Date: May 2005
Location: Chester, NJ
Posts: 11,231
Note to new Elise & Exige Owners:


1. These cars have large (i.e. dangerous) blind spots. Multivex mirrors are NLA, but RLS (Really Light Stuff) offers very good tape-on replacements.


2. The horns are way too weak (quiet). There’s an inverse relationship: smaller the car, louder the horn needs to be.

Get something such as a Stebel Nautilus.

Stock: “Excuse me”


Stebel: “HONK! LOOK OUT!”

Remove the stock horn; replace with louder.

(I drive with my finger on the horn button in any traffic. Iffy situations, my headlights are on.

Stay to the left of traffic, i.e. avoid passing on the right if you can.

Stop way behind trucks, SUVs, etc. Some have blindspots >50’. )


3. The early cars came with misaimed and dim headlights. If you drive at night, convert to HIDs. While better than stock halogen bulbs are available, HIDs throw more light. Stay around 5000k.


4. Ensure your car has had the work required by the recall for oil line fittings done. You could lose an engine and/or spin in your own oil.

5. The best transmission lube I’ve found is Redline MT-90 plus a little Power Punch Extreme Gear Oil Additive. (Note that it takes two changes to get rid of the previous lube.)

a) Early cars have wobbly shift towers. Look up Stan’s Mod (bolt and spacer; http://www.billswebspace.com/ShifterReinforcement.pdf) and

And, use:
Re-Enforcer long thru bolts that terminate under car and tie down the tower:
https://www.inokinetic.com/lotus/re-...y=Transmission

These (lube, mods) make a huge change in shifting.


6. As per some engine builders on these sites, wait AT LEAST 20 minutes after coolant has reached full operating temp before engaging cam switchover.

For street cars, consider removing one or both oil coolers. Some cover them.


7. Rear toe-links can loosen and break with disastrous results. You can check tq periodically, or use Nordlock washers. Best is conversion to better engineered brace, such as BOE’s InoKinetic’s for two examples.


8. While under the car with panel off, look around for hoses and wires chafing their way to failure. That’s how this was found:
https://www.lotustalk.com/forums/f311...-u-tube-47232/

9. The stock radiators are prone to leaking where the end caps meet the metal part. Keep an eye on this. Most of us use single-pass all-aluminum radiators.

10. When your wheel well liner comes loose, skip the lame plastic rivet and use Well-Nuts instead.

11. Life will be better if you disable the auto-arming alarm function on the earlier cars. You won’t have to press a button to start the car. Instructions:

https://www.lotustalk.com/forums/f320...ramming-70940/


12. These cars cannot be left off a Battery Tender for weeks at a time. Unless dead batteries are a particular joy of yours. Buy one right away. There are numerous threads here about which ppl use and like.


13, Some on this site are a bit obsessed with hockey pucks for lifting the car. Don’t use these. Too hard and slippery, generally, and too small a surface area. Use a piece of wood, as your hero does.

14. Visit the Uber Thread

https://www.lotustalk.com/forums/f3/e...ow-here-25131/

15. Most parts on the car are made by Toyota and others, so buying things like a/c compressors, engine parts, etc. is wildly expensive when purchased thru Lotus.
Toyota dealers, auto parts stores are way less expensive.

16. The soft high-grip tires on most of our cars lose much of that grip when temperatures drop below 50 F. I know of too many ppl who spun their cars when not remembering this. I use hi-performance all-seasons.

Note that many summer tires cannot even be stored in temps below 20 F.

-----

Plus, “How to bleed brakes”:

https://www.lotustalk.com/forums/f101...brakes-241138/


How to Search:

For future reference: Don't use the search on this site. Simply use Google and end the search text with "site:lotustalk.com". E.g.
Transmission Fluid change what bolt site:lotustalk.com no space betw site:lotustalk.com
Jetblast likes this.

05 elise (BOE Rev300 supercharged, SSRs, shift tower mods, Multivex; HID hi/low beams); 05 Corolla XRS. Past '72 Elan Sprint (I restored), Lotus 7 w/X-flow, TT Supra, Bugeye Sprite, BMW 2002 & 2002tii, '65 GTO.

Driving Tips-https://www.lotustalk.com/forums/f10...art-1-a-49665/
Moss Emergency Line-https://www.lotustalk.com/forums/f10...cy-line-36631/
Bleeding Brakes- https://www.lotustalk.com/forums/f10...-brakes-241138
glb is offline  
 
post #4 of 13 (permalink) Old 05-23-2019, 07:46 AM
Registered User
 
Join Date: Nov 2015
Location: massachusetts
Posts: 2,111
Did this thing get in a n accident, bent AC, broken brake reservoir....

if all else fails, the dealer has the wheel tool, not worse than you would expect pricewise
exigegus is offline  
post #5 of 13 (permalink) Old 05-23-2019, 10:01 AM Thread Starter
Registered User
 
E.Murray's Avatar
 
Join Date: Apr 2019
Location: SW MO
Posts: 94
Quote:
Originally Posted by kfennell View Post
1. Are the lines broken or just not plugged in, they actually come in and out of the reservoir pretty easy. If they are broke I think you're going to have to get a new reservoir if you're in a hurry but id doesn't NEED to be OEM.
2. That looks like a resistor pack box that has been relocated to that area so when it fails in the future its not a 6 hour job to change it.
3. That is a AC service port, that has been bent for sure, but if it's not leaking then it is what it is.

Someone will come on here with the tool available for sale They are in the $20s normally. I just use studs and nuts now.
So will the plastic pieces come with the reservoir rather than the master cylinder?
Where to the resistor packs come from (I'm assuming not OEM since it looks added on)?
I thought maybe the part in the AC line was a pressure switch or something with the electrical connection broken off. The line looks much more bent in the picture than it is, so I'm not concerned about that. I just don't have working AC, and am trying to hunt obvious stuff first.
Thanks for the replies.
E.Murray is offline  
post #6 of 13 (permalink) Old 05-23-2019, 10:09 AM
Registered User
 
kfennell's Avatar
 
Join Date: Jun 2015
Posts: 2,043
The resistor pack is to set the fan speeds on the HVAC fan. They fail in their oem location so people move them.

Why doesn't AC work. You need to give more to work with, no fan, not cold, compressor never kicks on, etc? I don't think there are any electrical connections to the AC piping up there? It's been a while since it was in my car.

Im not 100% sure what pieces that are broke I guess. Pictures man, try to help.

2007 Exige S with almost every track mod...
kfennell is online now  
post #7 of 13 (permalink) Old 05-23-2019, 05:43 PM
Registered User
 
SergeLotus's Avatar
 
Join Date: Nov 2017
Posts: 83
I got a new torx-style lug nut tool from Lotus of Greenville. If you don't want to wait for somebody on LotusTalk to sell you their's, Lotus of Greenville will order it for you and mail it to you. I honestly can't remember what I paid for it, but I don't remember it being stupid expensive. Ask for Robert Davies.

Robert Davies
Maserati Lotus Greenville
1450 Laurens Road
Greenville, SC 29607
(864) 255-3593 Office
(864) 235-3068 Fax
www.maseratilotusgreenville.com
SergeLotus is offline  
post #8 of 13 (permalink) Old 05-24-2019, 05:30 AM
Registered User
 
Jason Alderman's Avatar
 
Join Date: Apr 2017
Location: Southern California
Posts: 29
You need a 10 point spline lug tool for the wheel bolts. I picked this up from my local autozone and it works great:
https://www.autozone.com/ratchets-so...ocket/193871_0

4710 - 10-Point Tuner Lug Nut Socket
Jason Alderman is offline  
post #9 of 13 (permalink) Old 05-24-2019, 05:46 AM Thread Starter
Registered User
 
E.Murray's Avatar
 
Join Date: Apr 2019
Location: SW MO
Posts: 94
Quote:
Originally Posted by kfennell View Post
The resistor pack is to set the fan speeds on the HVAC fan. They fail in their oem location so people move them.

Why doesn't AC work. You need to give more to work with, no fan, not cold, compressor never kicks on, etc? I don't think there are any electrical connections to the AC piping up there? It's been a while since it was in my car.

Im not 100% sure what pieces that are broke I guess. Pictures man, try to help.
I haven't gotten into sorting through the AC yet. For now, I'm just trying to identify parts and get an assessment. I'll do my research when I get to it and ask more specific questions. So if the fan speeds work, this resistor pack is ok? Thanks for the answers.
E.Murray is offline  
post #10 of 13 (permalink) Old 05-24-2019, 06:02 AM
Race & Pamper
 
Kubera's Avatar
 
Join Date: Sep 2009
Location: Westchester, NY
Posts: 1,711
@E.Murray where are you located?
Kubera is offline  
post #11 of 13 (permalink) Old 05-24-2019, 07:01 AM Thread Starter
Registered User
 
E.Murray's Avatar
 
Join Date: Apr 2019
Location: SW MO
Posts: 94
I’m in Springfield, MO. One of the 5 Elise’s not in CA, lol!
E.Murray is offline  
post #12 of 13 (permalink) Old 05-24-2019, 07:37 AM
Registered User
 
Atomic Swede's Avatar
 
Join Date: Jun 2017
Location: Kansas City, Mo
Posts: 36
Quote:
Originally Posted by E.Murray View Post
I’m in Springfield, MO. One of the 5 Elise’s not in CA, lol!
There's quite a few of us running around Missouri. Local to me (the KC area) has more than I expected. Good luck with the repairs, I hope you at least had a little knowledge of what you were getting before it arrived.
Atomic Swede is offline  
post #13 of 13 (permalink) Old 05-24-2019, 08:51 AM Thread Starter
Registered User
 
E.Murray's Avatar
 
Join Date: Apr 2019
Location: SW MO
Posts: 94
Quote:
Originally Posted by Atomic Swede View Post
There's quite a few of us running around Missouri. Local to me (the KC area) has more than I expected. Good luck with the repairs, I hope you at least had a little knowledge of what you were getting before it arrived.
Fortunately (unfortunately?), this isn't my first rodeo - as we say in this part of the country. I just finished a 3-year full restoration on a '68 Corvette. The Elise isn't really a project. Just has a few things I need to address before putting into daily use. Good to know there are a few around here. The last time I saw one on the street was at least 3 years ago.
Attached Images
 
E.Murray is offline  
Sponsored Links
Advertisement
 
Reply

  LotusTalk - The Lotus Cars Community > Lotus Discussions > Lotus Elise

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Front Under Clam Protectors Elise/Exige SirLotus Parts For Sale 80 09-24-2017 07:38 PM
Looking for Front clam or Broken front Clam BoostinBird Parts Wanted 2 10-07-2012 02:32 PM
strange part fom under the front clam Mr.C General Discussion (Lotus related) 7 04-10-2007 06:19 AM
whats under the front clam lotus badge? elude General Discussion (Lotus related) 12 04-08-2007 09:24 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome