LotusTalk - The Lotus Cars Community

LotusTalk - The Lotus Cars Community (https://www.lotustalk.com/forums/)
-   Lotus Elise (https://www.lotustalk.com/forums/f259/)
-   -   What did you do to your Elise today? (https://www.lotustalk.com/forums/f259/what-did-you-do-your-elise-today-358841/)

xhifer 03-31-2016 10:57 AM

What did you do to your Elise today?
 
If there's another similar thread on here, please merge.

I just changed my spark plugs and oil along with filter on my 05 and it's a great feeling that the spark plugs still looks perfect with 40k and oil came out clean after 8.5k miles.

So, what did you do to your Elise today??

Enfield 03-31-2016 11:36 AM

Hi

I fitted a High Flow Induction kit and replaced the drivers side door pull (took ages to cut out the old one)

xhifer 03-31-2016 12:16 PM

1 Attachment(s)
Original spark plugs with 40k miles.

Noxx 04-01-2016 06:47 PM

Today I primed my boot cover. I'm in the process of repainting the whole car even though I have no experience in doing so...

http://s5.postimg.org/nlue9h4vb/1_1.jpg

Parko 04-01-2016 08:12 PM

Swapped wheels and tires, registered car for autocross this weekend.

Quote:

Originally Posted by xhifer (Post 4703105)
Original spark plugs with 40k miles.

Clean looking plugs--mine come out all black.

Quote:

Originally Posted by Noxx (Post 4705881)
Today I primed my boot cover. I'm in the process of repainting the whole car even though I have no experience in doing so...

Awesome! I really want to paint a car--I have less experience than you!

xhifer 04-01-2016 08:50 PM

I wish I had a booth to practice spraying.

Lotus F1 04-02-2016 02:28 AM

1 Attachment(s)
:grin2:

zero1954 04-02-2016 03:08 AM

I started detailing mine to get it ready to sell.

Nickshu 04-02-2016 03:25 AM

Installed a new wiper blade, Bosch Icon 24A. I think the one I removed is the original one.

Received my LED taillight kit today from EliseParts in the UK. Not looking forward to the yoga involved in installing it, but it looks really nice.

Ordered a Racebattery and Xtender2 bracket from Sector111.

Earlier this week got new tires (A048 LTS's), alignment and corner balance at a local race shop (SCR performance)....realized tires I removed were over 6 years old.

Cardinal#1 04-02-2016 07:08 AM

Quote:

Originally Posted by Nickshu (Post 4706257)
Installed a new wiper blade, Bosch Icon 24A. I think the one I removed is the original one.

Received my LED taillight kit today from EliseParts in the UK. Not looking forward to the yoga involved in installing it, but it looks really nice.

Ordered a Racebattery and Xtender2 bracket from Sector111.

Earlier this week got new tires (A048 LTS's), alignment and corner balance at a local race shop (SCR performance)....realized tires I removed were over 6 years old.



You will be happy with the new Bosch Icon wiper blade. I changed mine over one year ago from the original blade. It works great in the few rainstorms I've been caught in.


Sent from AutoGuide.com Free App

Noxx 04-02-2016 08:43 AM

Quote:

Originally Posted by Parko (Post 4705977)
Awesome! I really want to paint a car--I have less experience than you!

Dude, I have no experience in doing so, I'm learning as it goes!

Noxx 04-02-2016 08:48 AM

Today I pressed the hubs out of the rear uprights.

http://s5.postimg.org/dgrlpjduv/DSC_0313_2.jpg

chiarov 04-02-2016 09:02 AM

Quote:

Originally Posted by Nickshu (Post 4706257)
Installed a new wiper blade, Bosch Icon 24A. I think the one I removed is the original one.

Received my LED taillight kit today from EliseParts in the UK. Not looking forward to the yoga involved in installing it, but it looks really nice.

Ordered a Racebattery and Xtender2 bracket from Sector111.

Earlier this week got new tires (A048 LTS's), alignment and corner balance at a local race shop (SCR performance)....realized tires I removed were over 6 years old.

@niskshu - is this their aftermarket LED kit or the OEM one? Would love to know your opinion after install if it's the aftermarket one.

Nickshu 04-03-2016 09:19 PM

Today the Elise got:

Coolant drain and refill (Peak Global Lifetime)
A new thermostat. (OEM Toyota)
A new serpentine belt
Transmission oil drain and refill (Redline MT-90)
Coolant loop U-tube inspected and protected with a piece of split hose and zip ties.

The thermostat project really sucked. Most everything else wasn't too bad.
If I have time tomorrow I'm going to install a Stebel horn w/ relay and those LED taillights.

Falsey 04-04-2016 03:23 AM

Adjusted drivers side door yesterday because it was sagging due to previous owner(s) probably using it to push themselves up out of the car
👍

RichardNHCooper 04-04-2016 03:56 AM

Post track day
 
Refitted my Toyo R1Rs after yesterday's track day on Yoki 050s. Topped up the fuel tank with petrol on top of the 15 L of E85 left in the tank. My car runs flex fuel. So convenient!

Famous Frank 04-04-2016 11:15 AM

The vent on my boot cover was broken. When I removed it yesterday, it was obvious it was broken before as the was glue all over the place. Scraped off the old glue with a razor blade and glued the pieces back together with that new stuff you see advertised on TV. A clear liquid which only activates after being exposed to the UV Light pen that is included in the packaged. It worked extremely well. Now reinstalled! Glue was available at Walmart for $9.88 and worth every penny.

Today, I took the Elise to a local body shop to have the Hardtop Painted. The car is Graphite Grey. The Hardtop I purchased used here on the forum was Red. Having it repainted the original color will be terrific!

Can anyone tell me where to find the paint code so the body shop can order the correct color?

Many thanks,
Frank

xhifer 04-04-2016 11:24 AM

1 Attachment(s)
Gave her a good wash and wax.

xhifer 04-04-2016 11:28 AM

Quote:

Originally Posted by Famous Frank (Post 4710337)
Can anyone tell me where to find the paint code so the body shop can order the correct color?

Many thanks,
Frank

There should be a sticker between the driver seat and sills with a color code.

Nickshu 04-04-2016 04:49 PM

Installed Stebel horn today. Wired it with the Stebel relay kit taking power off fuse 1 accessory wire. Mounted the horn on the bottom oil cooler bracket as described here on the forum. I took out the stock horn... I considered leaving it because I read about the Stebel having a "lag" but I'm glad I didn't because I see no lag at all with the new horn. Man it sounds great! And LOUD!!


All times are GMT -8. The time now is 06:26 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome