Ronin Superchargers at Buttonwillow today... - LotusTalk - The Lotus Cars Community
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 10-23-2006, 11:31 PM Thread Starter
kaz
Registered User
 
kaz's Avatar
 
Join Date: Oct 2005
Location: Downtown LA
Posts: 2,894
Ronin Superchargers at Buttonwillow today...

Didn't know where to post so how about General?

Huge thanks to Jack, Shinoo, Neil and everyone at Sector for a great safe event today. Today was a great experiment seeing how Frank's and my SC's would hold up on a long day at the track. Frank's was amazing, it would just pull on the straights and sounded like those speeder bikes on SWEP6 on steroids. It ran in multiple run groups with several people driving it - obviously the intercooler is doing its job correctly.

Mine had the 10lb pulley put in recently and it also held up with the all day abuse. It ran in 2 groups (instructor took it out in advanced) so didn't have much time to rest, and water temps were initially 181 in the beginning of the day and rose to about 190 max toward the end. I don't have an EGT probe, or the fancy air charge temp gauges that Frank has, but the car was pulling hard all day. I also upgraded the springs on my single nitrons to 525/650 and the car felt amazing (muchas gracias Frank).

There were also 2 cup cars hauling ass as well as one Hass Turbo. All 4 supercharged Lotus cars performed great ...there was an issue with the Hass, don't know what it was or what it was related to -

2006 Elise : JFG | Nitrons | 2bular 8" Single | IMRP aero | TWRD carbon | K20/24 NA | DRS EFI/Cosworth dash and tuning
kaz is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 10-24-2006, 12:28 AM
Registered User
 
mikelr's Avatar
 
Join Date: Mar 2006
Location: Newburgh, New York
Posts: 1,498
Quote:
Originally Posted by kaz
...there was an issue with the Hass, don't know what it was or what it was related to -

OK, the barn door is now open...

14' Evora S
00' S1 Exige
94' S4 Esprit (SOLD)
mikelr is offline  
post #3 of 5 (permalink) Old 10-24-2006, 03:19 AM
purveyor of lightness
 
darkSol's Avatar
 
Join Date: Feb 2004
Location: Leawood, KS
Posts: 4,031
Garage
Quote:
Originally Posted by kaz
Mine had the 10lb pulley put in recently and it also held up with the all day abuse. It ran in 2 groups (instructor took it out in advanced) so didn't have much time to rest, and water temps were initially 181 in the beginning of the day and rose to about 190 max toward the end. I don't have an EGT probe, or the fancy air charge temp gauges that Frank has, but the car was pulling hard all day.
Kaz, how much water injection did you use - and what octane were you running for the 10psi pulley?

.
d.a..v...i....d

David Thomas Stewart - [email protected]
2005 Midnight Silver Lotus Elise (www.darksol.com)
388hp (342whp) BOE RevX 1736lbs.
darkSol is offline  
 
post #4 of 5 (permalink) Old 10-24-2006, 04:08 AM Thread Starter
kaz
Registered User
 
kaz's Avatar
 
Join Date: Oct 2005
Location: Downtown LA
Posts: 2,894
Quote:
Originally Posted by mikelr
OK, the barn door is now open...
Oh, didn't mean that as a jab or anything lol - could have been anything, could be nonHass related -

Quote:
Originally Posted by darkSol
Kaz, how much water injection did you use - and what octane were you running for the 10psi pulley?
Last time I was here since I only went through 1 gallon since it was just me driving and it's not like I was full throttle the whole way around. Since the car was running in 2 groups with my instructor driving it as well it went through a little less than 2 gallons - I am very glad I got the 1 gallon resevoir installed. Gas at first was half 91 half 100, then later full tank of 100.

2006 Elise : JFG | Nitrons | 2bular 8" Single | IMRP aero | TWRD carbon | K20/24 NA | DRS EFI/Cosworth dash and tuning
kaz is offline  
post #5 of 5 (permalink) Old 10-24-2006, 05:03 AM
Registered User
 
Dave's Avatar
 
Join Date: Apr 2005
Location: Ohio
Posts: 4,175
That's great news Kaz...sounds like you guys had a blast!
Dave is offline  
Sponsored Links
Advertisement
 
Reply

  LotusTalk - The Lotus Cars Community > Lotus Discussions > General Discussion (Lotus related)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome