Lotus Elise 05' - A/C Not Working - LotusTalk - The Lotus Cars Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-23-2019, 11:16 AM Thread Starter
Registered User
 
Join Date: Jun 2015
Location: Boca Raton, FL
Posts: 20
Lotus Elise 05' - A/C Not Working

Hello everyone,

So unfortunately I got caught driving in a major rain storm the other day and foolishly drove through a huge 3 foot puddle which completely intruded through the my floor board and shut off my AC. Now my blower motor nor my blue AC light will turn on. Where do you guys think on how to fix my AC problem?
kmedina8 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-02-2019, 05:54 AM
Registered User
 
Join Date: Nov 2018
Posts: 30
I've got a spare, new relay I can give you a deal on if you're interested. Same thing happened to the guy I bought my car from. He bought the relay and by the time it came in, the car had dried out and was working again.
Agent_86 is offline  
post #3 of 4 (permalink) Old 05-02-2019, 06:13 AM
Registered User
 
Crazy05's Avatar
 
Join Date: Sep 2018
Location: Apple Valley, CA
Posts: 167
Quote:
Originally Posted by Agent_86 View Post
I've got a spare, new relay I can give you a deal on if you're interested. Same thing happened to the guy I bought my car from. He bought the relay and by the time it came in, the car had dried out and was working again.
I was thinking the same thing... once it dries it could possibly work again.

Currently:
2005 Lotus Elise
2015 Audi A3 Wife's car
2012 Toyota Prius C Daily Commuter
Sold:
2006 Pontiac Solstice
2003 350z Touring
2006 Eclipse GT
Crazy05 is offline  
 
post #4 of 4 (permalink) Old 05-02-2019, 06:19 AM
glb
Registered User
 
glb's Avatar
 
Join Date: May 2005
Location: Chester, NJ
Posts: 11,029
Why start a 2nd thread on the same topic??


On the original thread, I wondered how you ended up in water that deep.

Please, if you don't mind, explain. Could be some learning experience for others...

Thanks.

05 elise (BOE Rev300 supercharged, SSRs, shift tower mods, Multivex; HID hi/low beams); 05 Corolla XRS. Past '72 Elan Sprint (I restored), Lotus 7 w/X-flow, TT Supra, Bugeye Sprite, BMW 2002 & 2002tii, '65 GTO.

Driving Tips-https://www.lotustalk.com/forums/f10...art-1-a-49665/
Moss Emergency Line-https://www.lotustalk.com/forums/f10...cy-line-36631/
Bleeding Brakes- https://www.lotustalk.com/forums/f10...-brakes-241138
glb is offline  
Sponsored Links
Advertisement
 
Reply

  LotusTalk - The Lotus Cars Community > Lotus Discussions > A/C, Heating and Ventilation

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
'05 Elise - Coolant Temp Gauge Not Working henrymfisher Lotus Elise 14 09-25-2018 11:38 AM
3rd brake lamp intermittently working and brake lamps not working when lights are off bboixtc Lighting 0 08-31-2018 03:35 AM
Instruments not working 05 Elise gcarpenter61 Electrical 9 10-08-2014 01:41 PM
Help! Another Headlight Not Working (Not Bulb, Not Harness, gets "some" voltage) evo4g63awd Lighting 20 04-15-2014 05:06 PM
[UPDATE] Attachments not working? - working now! and not working again!! zoltiz Lotus Talk Forum Feedback and Site Issues 23 12-04-2009 03:23 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome