RS14 Pads - Anyone here seen this? - LotusTalk - The Lotus Cars Community
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-17-2018, 10:06 PM Thread Starter
Registered User
 
Join Date: May 2012
Posts: 10
RS14 Pads - Anyone here seen this?

Over at SELOC there's a discussion going on regarding pulsing/juddering after running a few laps with RS14 pads... curious what this crowds thoughts are on the subject.

https://forums.seloc.org/viewthread.php?tid=452809

Consensus appears to be 100% for it being an uneven transfer layer from pad to disc. Exactly how or why though seems to be up in the air. Anyone here care to chime in?
ganzdachhaus is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-13-2018, 08:35 PM
Registered User
 
chiarov's Avatar
 
Join Date: Aug 2009
Location: Burlingame, CA
Posts: 1,208
Garage
I run those pads on street and track and have never had any issues.

2012 Porsche 991.1S white
2007 Exige S arctic silver (project)
2005 Elise magnetic blue/biscuit
2014 Audi Q5 3.0T scuba blue
chiarov is offline  
Sponsored Links
Advertisement
 
Reply

  LotusTalk - The Lotus Cars Community > Lotus Discussions > Suspension (including wheels, tires, brakes)

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome