LotusTalk - The Lotus Cars Community - Reply to Topic
Thread: 05 elise, ac blower not worker or wiper blade Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
10-26-2017 01:39 AM
KWin I had this problem, if it's intermittent, it's the key, when you start a normal car the key turns off accessories to get full power to the starter. The Elise is "too cool" for that and doesn't have the started wired into the key, this let's you push the key all the way to the start position and not have the starter chugging along the whole time. Try starting the car and make sure you rotate the key to the run position accessories like wipers should come back on.
10-25-2017 11:33 AM
howlinmark I have this problem with my 2005. Something in the ignition key barrel is loose. Gently wiggling the key usually solves the problem.
10-25-2017 10:52 AM
2ZZGE4ME Did you ever sort out this problem? I have a similar issue. My blower motor and wiper only work intermittently. I note that they have the same source, labeled "start drop out", which I think may be the issue.
01-10-2013 03:06 PM
tmr Do a search on the resistor pack problems for early Elise blower motors. If I'm not mistaken, fixing it involves removal of the front clam.
01-10-2013 12:31 PM
BoostinBird
05 elise, ac blower not worker or wiper blade

I am having an issue with my lotus elise, the wiper blade is not working and the a/c blower is not working maybe I have some electrical issues. Is the fuse box C for these issues


Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome