LotusTalk - The Lotus Cars Community - Reply to Topic
Thread: First major Elise repair: Installed a clutch Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-15-2013 02:13 PM
Shoof Nothing's going to happen if you installed the oem pp bolts back....replacing them is just a recommendation. I too just replaced the clutch and flywheel on my Exige, I went with the ACT HD-SS and Comp Clutches lighter steel flywheel. I also used the oem bolts with thread lock to make it secure, you should be fine. FWIW, my oem clutch had 6500 miles (how many miles i have on my car)of wear on it, I decided to change it by choice. Only thing I would have suggested was to have changed the flywheel while you were at it. BIG difference in the way the car revs.
05-13-2013 01:34 PM
Westrock I would totally recommend removing the clam to do this. Not that you have to, but you would be amazed at how much access you get. It is not very hard to remove the clam, it will add several hours of work though. But it is straight forward work.
05-13-2013 08:03 AM
zygotesoup Dude, fantastic write up! Bookmarked.
05-12-2013 09:42 AM
JohnnySniper
Quote:
Originally Posted by dma550 View Post
Normally all PP bolts are "stretch" bolts and they stretch as part of the torque process, right? Last clutch I did was a 911 turbo and I remember having to reorder a full set.
+1. You're "supposed to" replace the flywheel and pressure plate bolts with new ones. Either OEM or ARP (which are better and reusable).

I'm not sure if using the old bolts would really give you a problem though if they went back in fine.
05-12-2013 05:24 AM
dma550 Normally all PP bolts are "stretch" bolts and they stretch as part of the torque process, right? Last clutch I did was a 911 turbo and I remember having to reorder a full set.
05-11-2013 07:13 PM
wek120 Woa wait what? you need new pressure plate bolts? I installed the ACT HD-SS pressure plate and street disc earlier this year, and just re-used the stock bolts with a little red threadlocker. Is that bad?
05-11-2013 03:35 PM
JohnnySniper It's really convenient that you just made this how-to a month before I had to change my clutch.

THANK YOU SO MUCH!!!!!!!!!

I can't even explain how easy your guide made this for me. Took a few days to do it since I was just doing it after work but it really wasn't that hard. And I've never swapped a clutch before!
04-18-2013 04:02 PM
Nessal I will be using this guide when i do my clutch. Thanks!
04-18-2013 03:30 PM
SyTyArchives I just thought I'd follow up on the break in period. At the very beginning the clutch felt VERY grabby. I was getting quite a bit of chatter at very slow speeds where you have to slip the clutch a lot (like pulling into your driveway, or the pedestrian filled parking lot at work). It made quite a bit of noise and you could tell the engine was flapping around a bit.

It also HATED slipping when theres a significant difference in engine and trans rpm (like if you let clutch in, and the motor idles down, then you try to get it back into gear because the light changes - like you know... when you should rev match).

I'm happy to report it's characteristics are becoming much closer to stock after a few hundred miles. I almost feels less grabby, and it's quite a bit more forgiving at low speeds. had me worried for a bit, I really didn't want to take it back out so soon.
04-09-2013 05:25 AM
da40flyer Excellent write up!
04-08-2013 07:47 PM
nate379 Ah, makes sense.

Quote:
Originally Posted by addertooth View Post
He probably drained it so when the half-shafts were pulled, it would not leak fluid all over the place.
04-08-2013 12:55 PM
SyTyArchives Nice! Also somehow I missed the existence of said uberpost.
04-08-2013 07:16 AM
Doge Added to uberpost:

https://www.lotustalk.com/forums/f115...31/#post567611
04-08-2013 04:54 AM
David Craig That is a really impressive "How To" article. Well done!
04-08-2013 04:46 AM
Jim-C Nice job !
04-08-2013 04:31 AM
SyTyArchives Yes, I don't have direct experience of it puking gear oil, but assumed it would given that the axles are bathed in it inside the trans.

Thanks for the kind words. I still need to finish up adding in torque specs.
04-08-2013 04:19 AM
addertooth He probably drained it so when the half-shafts were pulled, it would not leak fluid all over the place.
04-07-2013 10:54 PM
nate379 Why did you drain the oil out of the trans?
04-07-2013 08:05 PM
Mr.C Really nice writeup.
Bookmarked for when the time comes to replace mine...
04-07-2013 01:49 PM
Doge Awesome write up.
This thread has more than 20 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome