LotusTalk - The Lotus Cars Community - Reply to Topic
Thread: How to Measure ECU Output? Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the LotusTalk - The Lotus Cars Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
07-03-2019 07:28 AM
BigHair
Quote:
Originally Posted by Nexus9 View Post
Yes, Very helpful.

So the device (in this case, solenoid) is either off or on. The ECU does not vary the voltage or provide an opposing voltage that allows a variable current. The transistor acts as a switch (you said that the first time,I didn't really get it) which provides a path to ground.

So one way of measuring whether the solenoid is being activated (correct me if I'm wrong) would be to measure voltage from the green 12v wire from the "Open Collector Output" to ground. When the solenoid is off (not activated by the ECU), this should read near battery voltage, but when (if) it is being activated, the voltage between the incoming green and ground should drop to near zero, as it is being "grounded" at the ECU. This will definitely answer if I have an ECU problem or a cam installation problem.

Really appreciate both you guys taking time to help me understand this - I never really knew how the ECU controls these devices, and you probably helped a lot of other folks reading this thread as well.

@Nexus9
Perfect!!! Thanx for hanging in there on the explanation. Best of luck with your investigation.


Sent from my iPhone using Tapatalk
07-03-2019 06:49 AM
eldonz
Quote:
Originally Posted by Nexus9 View Post
Yes, Very helpful.
So the device (in this case, solenoid) is either off or on. The ECU does not vary the voltage or provide an opposing voltage that allows a variable current. The transistor acts as a switch (you said that the first time,I didn't really get it) which provides a path to ground.
So one way of measuring whether the solenoid is being activated (correct me if I'm wrong) would be to measure voltage from the green 12v wire from the "Open Collector Output" to ground. When the solenoid is off (not activated by the ECU), this should read near battery voltage, but when (if) it is being activated, the voltage between the incoming green and ground should drop to near zero, as it is being "grounded" at the ECU. This will definitely answer if I have an ECU problem or a cam installation problem.
Really appreciate both you guys taking time to help me understand this - I never really knew how the ECU controls these devices, and you probably helped a lot of other folks reading this thread as well.
By George, I think he's got it!

Good Luck,
Eldon
07-03-2019 06:20 AM
Nexus9 Yes, Very helpful.
So the device (in this case, solenoid) is either off or on. The ECU does not vary the voltage or provide an opposing voltage that allows a variable current. The transistor acts as a switch (you said that the first time,I didn't really get it) which provides a path to ground.
So one way of measuring whether the solenoid is being activated (correct me if I'm wrong) would be to measure voltage from the green 12v wire from the "Open Collector Output" to ground. When the solenoid is off (not activated by the ECU), this should read near battery voltage, but when (if) it is being activated, the voltage between the incoming green and ground should drop to near zero, as it is being "grounded" at the ECU. This will definitely answer if I have an ECU problem or a cam installation problem.
Really appreciate both you guys taking time to help me understand this - I never really knew how the ECU controls these devices, and you probably helped a lot of other folks reading this thread as well.
07-02-2019 05:01 PM
BigHair
Quote:
Originally Posted by Nexus9 View Post
Oh, awesome - that is very helpful. I did not think the ECU provided that level of voltage, and I was laboring under the delusion that current flowed from the voltage rail through the chassis of the device to ground, and somehow the ECU enabled that.

So if I understand you, the solenoid is held "neutral" by an equal and opposing voltage that prevents current flow. The ECU controls the solenoid by lowering voltage and allowing current to flow through the solenoid, activating it, using the ECU as a ground. I'm surprised that that kind of current can flow through the ECU!

Okay, now I know what I'm looking for, I just need to set up the right device to capture the data. Can't tell you how much I appreciate your input, thank you again.
Just a little more info to help with your understanding...

The ECU is not really providing an opposing voltage to the solenoid, it is providing a path to ground via the switching device. This switching device will either be a relay or most likely a FET (Field Effect Transistor). Both of these devices have a low "On" resistance when energized; typically milli-ohms. So when the FET is turned on it basically shorts the solenoid to ground with very little voltage drop across itself due to the low "On" resistance. And when the device is "OFF" it has a very high resistance; Lets say infinite for this discussion.

So what is happening when you are monitoring the signal line from the ECU to the solenoid is you are seeing the voltage drop across the switching device for the open and shorted state. When in the "ON" state, the resistance of the switch device is very low compared to the solenoid coil resistance and the voltage drop measure is near zero. When in the "OFF" state the resistance of the switch device is near infinite compared to the solenoid resistance and therefore the voltage drop across the device is at the battery voltage.

This solenoid in series with the switching device form a basic voltage divider with two states and follow ohms law.

I hope this electrical theory discussion helps.
07-02-2019 04:37 PM
eldonz
Quote:
Originally Posted by Nexus9 View Post
Oh, awesome - that is very helpful. I did not think the ECU provided that level of voltage, and I was laboring under the delusion that current flowed from the voltage rail through the chassis of the device to ground, and somehow the ECU enabled that.

So if I understand you, the solenoid is held "neutral" by an equal and opposing voltage that prevents current flow. The ECU controls the solenoid by lowering voltage and allowing current to flow through the solenoid, activating it, using the ECU as a ground. I'm surprised that that kind of current can flow through the ECU!

Okay, now I know what I'm looking for, I just need to set up the right device to capture the data. Can't tell you how much I appreciate your input, thank you again.
The solenoid is being driven by what is referred to as "Open Collector Output". This means that there is a transistor that pulls the other side of the solenoid to ground. It is basically a very fast switch that is controlled by a processor output. The wire going to the solenoid from the +12 volt source is providing the positive power and current source. The ECU signal is actually an input that provides a path to ground via the transistor. So, when the transistor is off, both sides of the solenoid will measure around battery voltage. When the transistor is On, the ECU signal will typically measure below 1 volt.

Later,
Eldon
07-02-2019 03:52 PM
Nexus9 Oh, awesome - that is very helpful. I did not think the ECU provided that level of voltage, and I was laboring under the delusion that current flowed from the voltage rail through the chassis of the device to ground, and somehow the ECU enabled that.

So if I understand you, the solenoid is held "neutral" by an equal and opposing voltage that prevents current flow. The ECU controls the solenoid by lowering voltage and allowing current to flow through the solenoid, activating it, using the ECU as a ground. I'm surprised that that kind of current can flow through the ECU!

Okay, now I know what I'm looking for, I just need to set up the right device to capture the data. Can't tell you how much I appreciate your input, thank you again.
07-02-2019 03:24 PM
BigHair
Quote:
Originally Posted by Nexus9 View Post
Yeah, sorry - I'm not being very clear here, hopefully the attached photo will help.

Here's some VVT solenoids (and others) just as an example - each has two wires going to it. As you can see, they all receive voltage from the same IGN +15 rail, through 7.5 amp fuse R8, distributed to the different solenoids through E42, E43, E44 etc. But clearly, the VVT solenoids are not energized all the time; just some of the time, and the signal that allows them to energize comes from the ECU, i.e. E50/pink-red, attaches at ECU pin CB2. The solenoids are designed so that without the signal from the ECU, they are off, and they turn on (accept voltage from the rail) when the ECU signals the solenoid.

I can measure the voltage from the rail, of course - it is steady, and a known quantity. My question is, how do I know when (if) the ECU is sending a signal to the solenoid to activate? This is going to be intermittent, when the engine is running, and an unknown quantity.

OR, maybe its easier to post the actual problem. I regularly get a P0014 Bank 1 exhaust cam out of synch code when I drive over 4,000 rpm. I've replaced the sensor twice with no change. I've removed the solenoid and it's clean and jumps when voltage is applied, so the solenoid itself seems good. This means either the solenoid is not getting the signal to advance the cam, or the cam was installed incorrectly - or maybe something else I haven't thought of yet (?). So before I go through the mess of removing the valve cover, I was hoping to test the output from the ECU. Make sense?


If you monitor the wire coming from the ECU going to the coil it should be at 15 volts when the ECU is not driving the solenoid and it should be somewhere near 0 volts when the ECU is driving it on. The actual low voltage will depend on the solid state device used to drive the solenoid coil. In essence the ECU signal is acting like a switch connecting the coil to ground.

If the signal is long in duration, say 1 second, you can use a volt meter to detect it. If it is a fast pulse, then you will most likely have to use a scope because DVMs tend to have quite a bit of dampening built in to the instrument

Sent from my iPad using Tapatalk
07-02-2019 03:15 PM
Nexus9 Yeah, sorry - I'm not being very clear here, hopefully the attached photo will help.
Here's some VVT solenoids (and others) just as an example - each has two wires going to it. As you can see, they all receive voltage from the same IGN +15 rail, through 7.5 amp fuse R8, distributed to the different solenoids through E42, E43, E44 etc. But clearly, the VVT solenoids are not energized all the time; just some of the time, and the signal that allows them to energize comes from the ECU, i.e. E50/pink-red, attaches at ECU pin CB2. The solenoids are designed so that without the signal from the ECU, they are off, and they turn on (accept voltage from the rail) when the ECU signals the solenoid.
I can measure the voltage from the rail, of course - it is steady, and a known quantity. My question is, how do I know when (if) the ECU is sending a signal to the solenoid to activate? This is going to be intermittent, when the engine is running, and an unknown quantity.
OR, maybe its easier to post the actual problem. I regularly get a P0014 Bank 1 exhaust cam out of synch code when I drive over 4,000 rpm. I've replaced the sensor twice with no change. I've removed the solenoid and it's clean and jumps when voltage is applied, so the solenoid itself seems good. This means either the solenoid is not getting the signal to advance the cam, or the cam was installed incorrectly - or maybe something else I haven't thought of yet (?). So before I go through the mess of removing the valve cover, I was hoping to test the output from the ECU. Make sense?
07-02-2019 01:16 PM
Obeisance all solenoids I've ever seen are actuated by DC voltage application; i would recommend starting by measuring voltage.

edit: well, i guess i should be technically correct to say that the DC current energizes a coil that actuates a solenoid, but looking for a voltage should be sufficient.
07-02-2019 12:28 PM
Nexus9
How to Measure ECU Output?

I'm working on a 2010 Evora. Lots of solenoids, here, and most of them have the same configuration: The coil itself is wired to +12(ish) volts and grounded through the body. Easy enough to see if positive voltage is available. But the timing, or "actuation" of the solenoid is accomplished with another wire, which receives a signal from the ECU. What I want to know is if the solenoid is being activated at the right time, and the only way I can think to do that is to measure the signal from the ECU, but I don't know what I'm looking for. 12 volts? Am I even measuring voltage? A pulse? Square wave?
Anybody know how to measure the signal? Thanks

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome