The Lotus Cars Community banner

1 - 4 of 4 Posts
Q

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I'm going to remove my 2bular de-cat and stick my sport cat back on. (too friggin loud and too rich smelling)

Question... I have two possible downstream (post-cat) O2 sensor locations.

One is physically on the Sport cat, and there is also one in the middle of the u-pipe between the cat and the muffler.

My O2 simulator failed so I have a sticker-city cel-eliminator.

I'm wondering wich location I should stick the downstreatm O2 sensor (back side of the cat, or the U-pipe).

Thanks,

Q
 
Q

·
Guest
Joined
·
0 Posts
Discussion Starter #2
P.S. I'm also going to try out some Denso O2 sensors instead of the Bosch units.
 
Q

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Well... I'm still getting a CEL on the downstream sensor...

Sensor voltage is great on O2 sensor 1.

Sensor voltage is not outputting a sine wave on O2 sensor 2... just a flat .475 volts. Not sure if this is because of the StickerCity CEL eliminator... a faulty O2 sensor... or something in the wiring...

Car runs great on the Sport Cat... much more civilized then the decat pipe... but still mean sounding...

I am pooped!
 
Q

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Sensor voltage is not outputting a sine wave on O2 sensor 2... just a flat .475 volts. Not sure if this is because of the StickerCity CEL eliminator... a faulty O2 sensor... or something in the wiring...
Okay... I either have a bad sensor... or one of the wires is not completly soldered.

Steady voltage is an indication of the circuit not being complete and the heater circut in the sensor not working...

Time to disassemble the car... AGAIN!
 
1 - 4 of 4 Posts
Top