The Lotus Cars Community banner

1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
OK gents. I'm a newbie and this is my first post so please go gentle on me. I'm new to Lotus. In April I bought an 08 SC with 67K miles. Completely stock. The AC didn't work so my dealer had it for months and I just got it back. While he had it I had him install a new radiator(since the front clam was off), new Nitrons, and new exhaust from the manifold back , and a tune up(all for free . I supplied the parts). I got to drive it for a weekend when I first bought it and today was my first drive since. With the quieter stock exhaust I could hear the supercharger. My new exhaust is a top speed but I can't hear a thing from the SC. I can hear other parts of the motor, just not the SC. My question is how do I tell if my supercharger is still working? I'm sure I'm being silly because it still feels the same with regard to acceleration. Just a note I may have gotten impatient the past few weeks and pushed them on getting me my car so there may have been some rushing. OK, I may been a little more than impatient.

Thoughts?
 

Attachments

·
Registered
Joined
·
6 Posts
Discussion Starter #2
Anyone?

I went by mechanic today but he couldn't help because none his scanners could read it. He agrees with me though. He can't hear any super charger noise either. Would putting a hi flo CAT and exhaust effect the belt driven stock supercharger? Any advice would be appreciated.
 
1 - 2 of 2 Posts
Top