The Lotus Cars Community banner

1 - 10 of 10 Posts

·
Registered
Joined
·
381 Posts
Discussion Starter #1
is it normal that that shift light works only when traction control is turned off?
 

·
Registered
Joined
·
15 Posts
is it normal that that shift light works only when traction control is turned off?
i don't think so. Mine came on as expected today right around 8k with the TC on. I was just blasting along on the freeway so had no cause to turn it off. This is an '08 Elise SC.
 

·
Registered
Joined
·
381 Posts
Discussion Starter #7
yea when I turn off the traction control, the tell tale rpm works fine. As described in the manual, the lights will come on at max rpm, when the ecu thinks one should change gears, and time adjusted (have had it come on earlier when hard driving).

but when the traction control is ON, that means automatically everytime the car is started, there are no pretty lights. Will follow this up with the dealer. thanks
 

·
Registered
Joined
·
1,828 Posts
yea when I turn off the traction control, the tell tale rpm works fine. As described in the manual, the lights will come on at max rpm, when the ecu thinks one should change gears, and time adjusted (have had it come on earlier when hard driving).

but when the traction control is ON, that means automatically everytime the car is started, there are no pretty lights. Will follow this up with the dealer. thanks
That is just goofy if that is how it is supposed to work.

This was made out to be a new feature (which is true) but seems kinda gimmicky if you can only get it to work in those conditions. So Lotus and whomever came up with this new dash thought they would put in a couple of extra lights just to work when you turn off the traction control - which, as you pointed out, isn't how it defaults. Bizarre :thwack:
 

·
Registered
Joined
·
9,786 Posts
My download of the service manual includes the 2008 MY addendum... there is an explanation of how the three RPM tell tales work, but it says nothing about being disabled with T/C on or off.

So I'd guess that your RPM tell tales aren't working properly...
 

·
Registered
Joined
·
381 Posts
Discussion Starter #10
well, took the car in. they said it works at around 7500, and sure enough it does, but i could have sworn I took it to 8k before.

in either case, the shift light still isnt behaving as it does when the LCT is turned off. Im guessing now that this has to do with warning the driver earlier where power to speed nears situations where there may be loss of traction. a bit distracting... I hope this is it.
 
1 - 10 of 10 Posts
Top