The Lotus Cars Community banner

1 - 5 of 5 Posts

·
Andy
Joined
·
5 Posts
Discussion Starter #1
2005 Elise, 12k miles, stock shifter.

I noticed a shift into 2nd gear felt weird today, like 2nd gear was lower down than normal. As I continue driving, the shifter feels like its working itself loose. The gears feel fine and there are no noises or grinding; it seems like the location of the gears is shifting around.

Then I go to grab third and bam!, the freaking shifter becomes disconnected and is only held on by the leather boot.

How do I remove the shifter boot from the center console, so I can reattach the shifter?

Has this happened to anyone else? Thanks.
 

·
Andy
Joined
·
5 Posts
Discussion Starter #2
After doing some research, it looks like my car is part of the shifter recall but was not installed with the updated shifter.

The problem is that I am several hundred miles from the nearest Lotus dealer. Does anyone have any ideas on how to get an updated shifter? I am happy to pay my local shop to install it, but the lotus dealer I talked to says they cannot ship parts, the car would have to be brought to them. Thanks.
 

·
Super Moderator
Joined
·
2,843 Posts
I have a brand new updated shifter and the lift collar, but not the shift knob that you will need. Of course, I am not a Lotus dealer so you would have to purchase the parts from me, but I will discount them. If you are interested, PM me.
 

·
Premium Member
Joined
·
2,637 Posts
Are you certain it isn't a broken shift cable, it is another common failure.
 
1 - 5 of 5 Posts
Top