The Lotus Cars Community banner

1 - 20 of 69 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
As the title states I am rebuilding a canyon red 2011 lotus evora that was previously owned by lckitty. I'm going to be documenting the whole process so you can see what steps it took to bring it back to it's former glory. I hope also along this journey you guys will be able to help me with tips, tricks and things that I don't know.
So first things first, when the car came I noticed the clutch pedal was on the floor, after inspecting I found the master cylinder was cracked, so I replaced and bled the clutch. Now the car moves again under it's own power.
One thing that just started today was the alarm has been randomly going off, I've had the battery disconnect most of the time but for the last 3 days it's been left connected. I do know that the battery is weak and doesn't hold a good charge, but does anyone have an idea why the alarm would just go off?
 

·
Registered
Joined
·
276 Posts
I was thinking maybe the standard door switch issue, I'm not sure exactly what sensors are tied to the alarm but I would guess door switches and the trunk switch.
 

·
Registered
Joined
·
2,356 Posts
Given the front left impact I'd say check the driver's door first. Never had issues with the trunk.

Not surprised you needed a new master cyl. Clutch and brakes were on the floor after impact.
 

·
Disciple of Chapman
Joined
·
1,620 Posts
Will be interested to see if this build works out. Wishing you the best of luck
 

·
Registered
Joined
·
73 Posts
As the title states I am rebuilding a canyon red 2011 lotus evora that was previously owned by lckitty. I'm going to be documenting the whole process so you can see what steps it took to bring it back to it's former glory. I hope also along this journey you guys will be able to help me with tips, tricks and things that I don't know.
So first things first, when the car came I noticed the clutch pedal was on the floor, after inspecting I found the master cylinder was cracked, so I replaced and bled the clutch. Now the car moves again under it's own power.
One thing that just started today was the alarm has been randomly going off, I've had the battery disconnect most of the time but for the last 3 days it's been left connected. I do know that the battery is weak and doesn't hold a good charge, but does anyone have an idea why the alarm would just go off?
It probably has nothing to do with your alarm problem, but I found that if I left my iphone or ipad in my Elise it would trigger the alarm.
 

·
Registered
Joined
·
856 Posts
I would think so as my car definitely indicates when it senses a door or trunk open.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #9
I was under the impression that all evoras had some version of oil/coolers in the front of the wheels in the vent on each side of the bumper? I see no coolers and no oil lines
 

·
Illegal Alien
Joined
·
5,278 Posts
S and ISP cars only, have front coolers
 

·
Registered
Joined
·
276 Posts
You don't want the oil lines anyway, they're the parts that keep getting recalled.
 

·
Illegal Alien
Joined
·
5,278 Posts
You don't want the oil lines anyway, they're the parts that keep getting recalled.
Not exactly, 1st evora oil line recall was a oil lube line to the vtt on pre 12 S cars, 2nd was oil cooler line in engine bay on pre 12 S cars.
 

·
Registered
Joined
·
276 Posts
My bad, thought the first recall was also for an oil cooler line.
 

·
Registered
Joined
·
2,356 Posts
No oil coolers on this one. Ref; LED lights thread.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #15
Ok so a little bit of an update. After taking apart most the front end of the car and inspecting all parts that are undamaged and reusable, I have have gotten the original estimate of $36000 in parts down to around $11000, the only exception is I am going to repair the clamshell.
Yes I was looking for oil coolers because the original estimate quoted that they needed to both be replace.
I will upload some pictures tomorrow of it torn down.

If someone could help me, I could use some picture of the underside of the clamshell, specifically the front and side mounting points. I can see that there was a bracket of some sort attached the the front end of the clam. but could use some help understanding how it bolts up with the sub-frame rebar and front bumper.
 

·
Registered
Joined
·
216 Posts
Jordan do you have the 2009 service manual? It is a big help with disassembly.
 

·
Registered
Joined
·
626 Posts
1 - 20 of 69 Posts
Top