The Lotus Cars Community banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have quite a few sport cars but I enjoy driving my Lotus. The problem I am having is one hot day driving over the pass I instantly loss power but a was able to make it home. Check out the car to me it sounds like it not getting enough air and it starts but does not idle.

I checked the air cleaner, the compression was all the same, checked the muffler for blockage, and the turbo. But when you drive it, the turbo is not kicking in and I normally would hear the fluttering of the waste gate after acceleration which I do not. I can usually figure out most things but here in Bend, OR there are no shops that work on Lotus's. I love the 4 cyl for gas mileage and when the turbo kicks in there's plenty of power (love it). It just does not rev up and seems like an air problem

Does anyone know a mechanic in Oregon that is reasonably or might have had this problem as well. Please help as I really want to enjoy this car this summer.

Thank you
 

·
Registered
Joined
·
4,852 Posts
You should have a MOD move this to the Esprit section.

There is a butterfly valve just below the catalytic converter that is opened, once the car is warm, wit a vacuum capsule. This is the Exhaust Back Pressure Valve (EBPV), it is meant to help warm the cat up faster. They often fail closed and will prevent any boost, and pretty much prevent the car from driving well at all.

Check that valve, and wire or bracket it open if you have to.
Looks like this


If that is not the problem, then it could be a blockage in the cat as well, they do sometimes break up.

If not those, then it could be a poor spark condition, or a fuel problem like a bunch of clogged injectors or a bad pump.
 
1 - 2 of 2 Posts
Top