The Lotus Cars Community banner

1 - 2 of 2 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1 (Edited)
Hey guys. Since I bought my 2005 Elise the ABS light has been randomly off/on. After I got the car inspected, it came on and stayed on. Since it's time to get the car inspected again, I decided it was finally time to look into the problem and fix it.

After reading some posts, I decided to pop the wheel off to see if one of the speed sensor wires was worn through. Sure enough the left front wheel sensor wires weren't just worn through, they were completely ripped out!



In the picture the wire ends are supposed to connect to the blue posts, which are soo short soldering them back on would seem to be impossible.

Any advice on what i should do? Where can I buy a new wheel sensor? How hard is it to install (I have a friend with an auto shop, and no dealerships around me).
 

·
Registered
Joined
·
846 Posts
Hey guys. Since I bought my 2005 Elise the ABS light has been randomly off/on. After I got the car inspected, it came on and stayed on. Since it's time to get the car inspected again, I decided it was finally time to look into the problem and fix it.

After reading some posts, I decided to pop the wheel off to see if one of the speed sensor wires was worn through. Sure enough the left front wheel sensor wires weren't just worn through, they were completely ripped out!



In the picture the wire ends are supposed to connect to the blue posts, which are soo short soldering them back on would seem to be impossible.

Any advice on what i should do? Where can I buy a new wheel sensor? How hard is it to install (I have a friend with an auto shop, and no dealerships around me).
easy install, pull wheel, pull disk, pull the three bolts on the back...
Once you get the thing off there, if you could tell me how many teeth are on the internal gear I would be much appreciated.
You can get the bearing from lotus garage, all 4 wheels use the same part.
 
1 - 2 of 2 Posts
Top