The Lotus Cars Community banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hellow everyone.
My 09 EVORA LAUNCH ED has three warning light issues.
ABS TRC BRAKE TELL TALE are stay on.
But these are working perfectly.
Parking brake switch is OK.
Brake fluid sensor is OK.
Wheel speed sensor was cleaned.
Tested disconect battery to reset ECU.
but couldn't turn off.

What do you think about these issues?
Please let me know.

THANKS
 

·
Registered
Joined
·
389 Posts
welcome to the forum... your forum name got me intrigued since my last name is Maru.


Check the steering angle sensor... mine was going bad and it would throw all of those lights every now and then.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks for the advice,MrMaru!
I will check this weekend as soon as possible.

Oh,I have a question.
Are cruise controll and sports mode working in your case?
Cruise controll is working with no issue,
Sport mode is working without [SPORTS] tell tale turn on in my case.
 

·
Premium Member
Joined
·
2,640 Posts
Maybe not relevant but my Xterra has ABS, T/C, VDS[stability ] lights on due to a bad abs sensor

have the replacement, just getting to it.....keeps me out of 4wd

so, first time in nearly 20 years driving a RWD car with no interventions in the snow

woooo hooo
 

·
Registered
Joined
·
389 Posts
Thanks for the advice,MrMaru!
I will check this weekend as soon as possible.

Oh,I have a question.
Are cruise controll and sports mode working in your case?
Cruise controll is working with no issue,
Sport mode is working without [SPORTS] tell tale turn on in my case.
all of it works for me.
 

·
Illegal Alien
Joined
·
4,979 Posts
How are you confirming Sports mode is working when you don't have a light indication?
 

·
Registered
Joined
·
597 Posts
How are you confirming Sports mode is working when you don't have a light indication?
It would seem to require not much more than application of the right foot... :scratchhead:

To the OP (one of the super Maru brothers!), do you have a scanner that can read wheel speed at each wheel in real time? If you do have a bad sensor at the wheel, that could help pinpoint it. But as (the other) MrMaru says, the steering angle sensor is a known issue with the Evora.

But why not just read the code first? Always a good start.
 

·
Registered
Joined
·
4,284 Posts
The fact that "read the light" wasn't mentioned until post #7 is worrying...

Read the dang light. It'll tell you (most likely) what sensor is wrong.
 

·
Registered
Joined
·
389 Posts
The fact that "read the light" wasn't mentioned until post #7 is worrying...

Read the dang light. It'll tell you (most likely) what sensor is wrong.
In my experience, reading the code has not helped in any of my situations. The dealership literally checked the connection in the entire front harness to find the issue with the steering angle sensor to be having an intermittent issue. My entire dash would just lose power and light up like a Christmas tree. The steering angle sensor was also the cause of my traction control light going off all the time and then I would not be able to use sport mode at all.

Airbag light comes on and the code doesn't tell me anything. Turned out to be connectivity voltage was off my like minute amount. They used some kind of compound and it cleared right up.
 
1 - 11 of 11 Posts
Top