The Lotus Cars Community banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi guys,

I am new to the forum so hello all,

I have read pretty much every thread i can find on the net re AC issues. After all of the below the AC on my 2008 Elise S (RHD) still has the habit of not always wanting to turn on when the button is pressed (i.e. Increased revs, engage compressor clutch and blow cold). Sometimes it will come on but will switch itself of after 10 or so mins and then not come back on for 15.

I don't think its an ice issue as i can't possibly have ice at start up when AC has not even been running.

I am thinking it must be electrical. So far i have done the following.


De gassed / Re gassed twice.
Changed the Relay Switch.
Had AC clutch checked (When AC truns it runs ok anyway so that should be fine)
Bypassed the Trinary switch by hot wiring the relay switch (this was only to test). The AC came on OK.
Read articles about the thermostat. which i think is A hard to get at on RHD and B probably not the cause.

My next move is to replace the trinary switch which won't be easy and will require another de-gass etc.

Any suggestions that you may have would be greatly appreciated.

Graham
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
Further to the above. a number of engine restasrts will eventually result in the AC coming on again.
 

·
Premium Member
Joined
·
2,307 Posts
I think it more likely the switch pack module, but you could figure out the logic of the trinary switch without removing it

It does the fan and clutch both of which I think go through the ECU and the switch pack
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
I have replaced the Relay Pack already and no change. Unless the replacement had the same fault which i doubt?
 
1 - 4 of 4 Posts
Top