The Lotus Cars Community banner

1 - 8 of 8 Posts

·
Registered
Joined
·
796 Posts
Discussion Starter #1
I removed the front clam, then put it back on last month. Since then I've noticed a slight squeek when i turn right -- but only with the AC on. it definitely sounds like the AC that is making the noise. turning left, no problem/no noise. It did not do this before I removed the clam.

anyone have an idea what I might have done?


Thanks in advance!

Michael
 

·
Registered
Joined
·
106 Posts
Lotus Technical Bulletin recommends no turning right, only 3 left turns..... Kidding. I'm sure SirLotus will be around shortly to give you a much more useful answer.
Don
 

·
Registered
Joined
·
796 Posts
Discussion Starter #5
sighhhh... i was hoping for a "you didn't do ____ dummy"... but refitting the clam will be what i will do. thanks Michael!!
 

·
Registered
Joined
·
796 Posts
Discussion Starter #7
well I'm glad I'm not a dummy... at least not today. :p

yea -- it is definitely odd. maybe when the car shifts to the right (everything is pushed with G forces left) a hose or something gets pinched causing the noise i hear.

I don't have time to go diving into it, so I'll just drive it for a month or so. if it bugs me too much I'll tear it up some. :)

thanks again Sir and Raz. :)
 

·
Registered
Joined
·
6,930 Posts
well I'm glad I'm not a dummy... at least not today. :p

yea -- it is definitely odd. maybe when the car shifts to the right (everything is pushed with G forces left) a hose or something gets pinched causing the noise i hear.

I don't have time to go diving into it, so I'll just drive it for a month or so. if it bugs me too much I'll tear it up some. :)

thanks again Sir and Raz. :)
Let us know if you solve this bizarre mystery :crazyeyes.
Michael
 
1 - 8 of 8 Posts
Top