The Lotus Cars Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
I finally got my Evora, took a while,, so this weekend we went to Deals Gap, I place I know really well from my racing days,,, anyway the stereo sounded aweful.

So from what I can tell,, the rear speakers are not working and the Sub Woofer selection seems to do nothing.

Any pointers would be great as I know the system cant be that bad can it?

Thank you
 

·
Registered
Joined
·
361 Posts
I finally got my Evora, took a while,, so this weekend we went to Deals Gap, I place I know really well from my racing days,,, anyway the stereo sounded aweful.

So from what I can tell,, the rear speakers are not working and the Sub Woofer selection seems to do nothing.

Any pointers would be great as I know the system cant be that bad can it?

Thank you
I recently played with my settings off of the phone/usb cord. I found it easier to use then the dash. You can also create an account in their cloud, save scenarios to go back to, etc.

In my case, I believe the subwoofer was off, and some other things.
 

·
Premium Member
Joined
·
2,161 Posts
I finally got my Evora, took a while,, so this weekend we went to Deals Gap, I place I know really well from my racing days,,, anyway the stereo sounded aweful.

So from what I can tell,, the rear speakers are not working and the Sub Woofer selection seems to do nothing.

Any pointers would be great as I know the system cant be that bad can it?

Thank you
a) the stereo is awful
b) there are no rear speakers. Many Evora owners of all generations have reported issues with the subwoofer. Why, I don't know, but see if it's on at all. You will have to get out of the car and go around to right near the speaker. If it's not, first check all of the settings. It can be turned on/off, volume reduced/increased, cross-overs adjusted, etc. Then check wiring, fuses, etc.
c) there are several posts around on how to adjust the settings overall for the head unit. But at best, it's not not great
d) replace the front speakers. It's easy and pretty cheap. Several posts on this.
 

·
Galactic Hitchhiker
Joined
·
384 Posts
I think it's a pretty nice unit, but the nav is near useless as there's no way to get real-time traffic to it. The EQ section is actually pretty great. It's the only part of the system I kept.


Both the sub and the sub amp are terrible, and on top of that, the amp tends to fail.

You've got woofers in the doors, and tweeters in the dash.. crossovers for them are mounted behind the kick panels. They're reasonably easy to replace.. and like Dylan said, there are lots of posts about it. Getting a 3 channel amp to power all of the speakers will go a long way in getting you some fidelity.

good luck!
 

·
Registered
Joined
·
1,468 Posts
I agree with Dylan...the stock system is awful. I had the Alpine INA-W900 in mine and the first "mod" I did to the Evora was replace it. I couldn't stand its functionality and looks. I ended up replacing everything with a Pioneer AVIC-8200NEX HU, Kicker low profile sub, JL 3 channel amp and new speakers. Made a world of difference.
 
1 - 5 of 5 Posts
Top