The Lotus Cars Community banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello all. Here is a rant about my clutch.

I replaced my stock clutch on my S1 Elise, with, erm another stock clutch about a year ago.

Put the car in the garage for the winter, got it out in the spring and there was fairly crippling slippage.

The clutch was bled, which successfully resolved the issue for about 4-6 weeks, then the slippling came back. (Juddering when engaing the clutch, and when in gear not 'pulling' at 100%)

Recently eplaced red clutch hose for a braided one, and slave cylinder.

The clutch now bites very high, and when I accelerate in say 2nd or 3rd, the sensation can best be described as "driving with the clutch depressed 1/4 of an inch" . I.e. the revs slighly jump up, but not 100% of the power is getting through to the wheels.



So, for my money, my clutch is ****ed. Knowing very little about this, would you agree?

Secondly, what after market - or non stock clutch would you advice to get. I dont do track days, just normal and fun road use.

Thirdly - any idea how much it costs (labour) at a Lotus garage to do this job.

Hope you can offer me some advice- i'd appreciate it.

Thanks.
 

·
Registered
Joined
·
1,966 Posts
For an S1 you'd be best off asking on Seloc.org, not many S1s made it over here. Our clutches are Toyota, like the engine and transmission.
 

·
Registered
Joined
·
1,966 Posts
mmm I'm from Birmingham......not the Alabama one, the England one!

Looking at the locations, it seems i'm in the wrong country!?
Not so much wrong country, as wrong model Elise/Exige.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top