The Lotus Cars Community banner

1 - 17 of 17 Posts

·
Registered
Joined
·
2,464 Posts
Discussion Starter #1
This thread originated in the psc forum.
This guy had bad radio reception and someone suggested to see if the radio was set to US or UK and to check in the manual and it's true!! there is a setting for US vs Europe.

My reply after checking the manual:

xclusivecar said:
Check to make sure your radio is set for the USA and not the UK! My radio came set to the UK and I could not tune into much at all. After I set it to the USA, all channels magically appeared and are extremely clear! Your manual on the radio can show you how or I can look it up if youd like! Good luck.

Good thing to know, here is what I found on the manual.

Radio mode

Setting the tuner

To ensure that the tuner works properly, the device must be configured for your region. You can choose between Europe and the USA. By default, the tuner is set to the region in which the device was sold. If you experience problems with radio reception, please check these settings.

- Press the MENU button 8.
- Press the softkey 4 assigned to the “SETP” display item.
- Press the softkey 4 assigned to the “AREA” display item.
- Press the softkey 4 assigned to the display item of the region that you require: “EURO” or “USA”.
- Press the joystick OK 7 or the MENU button 8 to close the
menu.

The settings are saved.
 

·
Forum Founder
Joined
·
29,083 Posts
My reception was very good off the floor. I had to set the equalizer settings from the default "cat-fighting-at-midnight" setting, but other than that... no problems.
 

·
Registered
Joined
·
426 Posts
My car is being serviced as we speak. From what I understand, a "bad connector" is causing ignition interference. I'll keep everyone posted on how things go. I should be picking it up soon.
 

·
insert clever title here
Joined
·
7,702 Posts
My reception was great, but after setting it to USA (not sure what it was set to before), the scan function picked up a LOT more stations.
 

·
Registered
Joined
·
57 Posts
My reception is great since I changed the setting from Euro to USA. Drove around for a week cursing the thing and then *presto* all my stations appeared! Definitly mess with the user defined setting for the EQ. Makes a BIG difference in sound quality!
 

·
Registered
Joined
·
1,766 Posts
I went thought all the radio settings today, including the equailzer, it sounds better, an lot better. It does need to be set to USA though.
 

·
Registered
Joined
·
426 Posts
I just got my car back. They played around with the antenna and moved it in a better position as well as replacing one of the connectors. It's about 50% better, but still bad, with just about nothing coming in below 700 on the AM dial because of the ignition interference. FM is pretty decent.

I'm really surprised that the aftermarket hasn't found a solution for this. A fix has got to be a huge market, with just about everyone having poor reception.
 

·
Registered
Joined
·
6,293 Posts
640AM works fine for me...but I am too embarrassed to let any other motorists hear me listen to it...
 

·
Registered
Joined
·
12,374 Posts
Joetz said:
the AM dial
AM dial? What's that? I'll bet most people won't notice or care because most everyone listens to FM. That's not to say it isn't frustrating, but it probably doesn't apply to most people...
 

·
Registered
Joined
·
94 Posts
I had horrible reception with my stereo. When I took my car in to get the 1000k service I had it checked and they determined that the antenna was bad. They ordered a new one....they temporarily fixed it by taping a very small screwdriver to the end of the antenna.

Jeff
 

·
Registered
Joined
·
262 Posts
TimMullen said:
AM dial? What's that? I'll bet most people won't notice or care because most everyone listens to FM. That's not to say it isn't frustrating, but it probably doesn't apply to most people...
I guess I'm the odd ball then because I only listen to AM radio. When I listen to music I play MP3 discs that I've created.
 

·
Registered
Joined
·
779 Posts
AM? whats that.. :confused:

When I was in Cali I went to a Shop Called LaJolla Audio
Some lady was getting $60k (Rainbow,Buttler,Denon,JL)in audio & custom work on her New Rolls
The guy asked her what radio she lisons to & it was all talk radio..

was kinda funny cuz the stuff she got you could almost her the host Fart..or breath..lol


Troy :nanner:
 

·
Registered
Joined
·
3,826 Posts
AM here in the morning, I need my 880 WCBS to find out what's happening in the world. Also my AM sucks eventhough I have an Alpine HU. I think its the antena position and it's proximity to the Electical junction boxes.
 
1 - 17 of 17 Posts
Top