The Lotus Cars Community banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2,894 Posts
Discussion Starter #1
Took nice leisurely drive this morning, went to car wash to wash away the grime from Friday. PreIC temps were normal around 140-220 based on left foot, PostIC 80-100 - all normal. After car wash the PreIC registered 440 and the PostIC 80. Drove around a bit the PreIC registered 330 and post still around 80-90. There's no way my corecharger is taking out 360 degrees right?? I assume it's water or something coincidental with a bad temp sensor or something. First I thought my MP62 coatings had finally scraped off and the SC was putting out a ton of heat, but there's no way my intercooler takes out 300degrees (wish it did!)
 

·
Registered
Joined
·
845 Posts
Peter, you wash your car at a car wash? -poke-

I could definitely see the high pressure spray wreaking havoc on the sensors.
 

·
Registered
Joined
·
2,894 Posts
Discussion Starter #4
hand wash, clay wax :) this place on La Cienega I been going there since I bought the car - gonna let the car cool down and go out again see if it went away, it's incredibly beautiful outside and I haven't seen my car this clean for a long time
 

·
Registered
Joined
·
9,786 Posts
Took nice leisurely drive this morning, went to car wash to wash away the grime from Friday.
:no:

Can't you get some of the Brolly Dollies to "hand wash" your "ride"?

I had higher expectations for you Peter... :D
 

·
Registered
Joined
·
2,894 Posts
Discussion Starter #7
yeah it went away...water...bad
 
1 - 8 of 8 Posts
Top