The Lotus Cars Community banner

1 - 7 of 7 Posts

·
Registered
Joined
·
373 Posts
Discussion Starter #1
Hi, folks,

Recently my brake light has been on sporadically. When the ebrake is up, the light is very bright, then when I put the ebrake down, the light remains on but is fainter. After I drive a few miles, it tends to fade out. I've noticed that this happens more after wet weather. I plan to bleed the brakes a bit this weekend, but as far as I can tell, they are all installed ok. I had a bit of a brake mishap (ahem, but it was all clean and no damage) at the track, and replaced my rears with Pagid Blues that were just partly used. I've got Hawk HT10's in front. Been a bit lazy about swapping them out.

Is my brake light coming on as a kind reminder that my front brakes aren't street legal? :evil: Any other theories? :)

Wendy
 

·
Registered
Joined
·
373 Posts
Discussion Starter #3
Last I checked it was. I can't remember if I've checked in the past couple of weeks, and this started happening around then. I'll check again tomorrow first thing.

Btw, Viper, I've been following your AC mods. My AC is not working at all and I get nothing but hot air from the vents. I'm trying to carve out some time to do those. Different thread but thought I'd mention it. :)

Wendy
 

·
Registered
Joined
·
6,961 Posts
Wendy, if you are getting no cold air maybe the refrigerant is low.
michael
Last I checked it was. I can't remember if I've checked in the past couple of weeks, and this started happening around then. I'll check again tomorrow first thing.

Btw, Viper, I've been following your AC mods. My AC is not working at all and I get nothing but hot air from the vents. I'm trying to carve out some time to do those. Different thread but thought I'd mention it. :)

Wendy
 

·
Registered
Joined
·
373 Posts
Discussion Starter #5
Yes, filling the refrigerant was what I was going to do first. It's the easiest and laziest mod for me to do. :) I did get the sensor fixed under warranty about 1.5 years ago. Do you think the refrigerant would leak out that quickly? (it doesn't in my other cars. ;))
 

·
Registered
Joined
·
373 Posts
Discussion Starter #6
I did check my brake fluid and it isn't low. However, the fluid reservoir screw top with wires was turned in such a way that the wires were jammed under the cover. I turned that around to face the other direction so it won't be jammed, and will see if the light stays off. Hopefully it's that easy. I'm driving the car later today, but not this morning (some kid pickup at noon) and then I'll know if it was as brain-dead simple as that.
 

·
Registered
Joined
·
30 Posts
Sometimes when I lower the e-brake, the light won't go out. If I re-set the ebrake and make sure to keep the button pressed while lowering, the brake light goes out. For some reason, the brake must be set. Just raising and lowering the handle doesn't do anything. I'm too lazy to adjust it properly, if that's even possible.
 
1 - 7 of 7 Posts
Top