The Lotus Cars Community banner

1 - 20 of 28 Posts

·
Registered
Joined
·
5,607 Posts
Discussion Starter #1
I know I read some threads about cars who had BROWN SPOTS on their starshield.

Our orange car is fine, not a spot on her. But this yellow car has BROWN SPOTS all over the starshield and we've only had the darn car a week and a half! They dont want to come off and they look terrible. It looks like the car is dirty all the time.

I did a search and couldnt find the threads.

Anyone resolve how to clean these brown spots and/or figure out what to do???
 

·
Registered
Joined
·
2,344 Posts
I had this mental image of your car looking like an overripe banana. Don't suppose anyone can photoshop that?

Cade
 

·
Registered
Joined
·
5,607 Posts
Discussion Starter #7
Nope. They're brown spots that appear to be under the surface.

Our first car has nothing like this on it. This one is covered in the spots.

I tried to call starsheild but kept getting a machine. Noone has called back.
 

·
Registered
Joined
·
35 Posts
Hmm, I would have the dealer look at it. If they are spots of dust etc. under the material or spots on the paint they should replace it under warranty as it wasn't installed correctly in the first place... While it is not unexpected to get a few spots of dust etc under it during the install, it shouldn't look like it is seasoned with pepper.
 

·
Registered
Joined
·
6,301 Posts
I have 2 or 3 brown spots visible under the clear bra - noticed the first time I washed, and haven't seen any new ones since....
 

·
Registered
Joined
·
5,607 Posts
Discussion Starter #11
Some pics. These pics arent very good. Basically the spots are all over the car under the starshield.
 

Attachments

·
Registered
Joined
·
1,122 Posts
A number of people have reported this problem. Not sure what the outcome was, but I'm sure some of them will respond in time.
 

·
Premium Member
Joined
·
29,081 Posts
My Starshield was replaced so the spots are gone. Sorry. I have not gotten any new spots since (4 weeks ago).

I am pretty sure that the only spots I got on the film were from bugs or something around the beginning of my road trip.
 

·
Registered
Joined
·
3,664 Posts
I haven't noticed any brown spots on mine... just a nasty black fingerprint and lots of tiny air bubbles :rolleyes:

Lotus never got back to my dealer about this or the marks and dull spots in my paint... I'm probably going to call the dealer again today.
 

·
Registered
Joined
·
3,914 Posts
wow OFL, that looks pretty bad!
I have a SY car and no spots on/under the starshield. these spots appeared within the last week? on the other thread someone suggested maybe it was some mold underneath; I wonder if this could be it.

the only issue i have with the starshield is that my driver side front plastic grill is broken and glued in place! I pointed this out to the service manager at SVAG and he thought it could have been damaged during the starshield installation. He offered to fix it under warranty so I have no worries. This is OT, but I thought I'd mention it since it is somewhat related to starshield.

i haven't noticed any spots or dust or bubbles. the installation is done pretty well save for a few crooked edges.
 

·
Registered
Joined
·
5,607 Posts
Discussion Starter #18
these spots were on there when I got home from Atlanta...I'd owned the car 1 day when they appeared.

I've dealt with my fair share of tar and bugs, but this is like a stain. As if maybe a bug got splattered and stained the plastic. But what good is a plastic that stains so easily that you have spots all over after 24 hours of ownership and you paid $1000 extra for it to boot?
 

·
Registered
Joined
·
472 Posts
Jenn,
Can you tell if the spots are on the outer surface of the film or between the film and paint? If the spots are really shiny, they are probably between the film and paint, indicating a problem during installation (maybe some residual cleaner left on paint after prepping for the installation?). If the spots are on the outer surface of the film, you should be able to get them out using rubbing compound (followed by glazing compound and wax to restore the shiny surface). I have a similar 3M film on several other vehicles (headlight covers, etc.) for at least six years with nothing like the spots you're finding. I would guess that the problem is between the paint and film, only because I haven't seen any road debris that stains the film.
Good luck, and for sure let us know the resolution.
Jim
 

·
Registered
Joined
·
5,607 Posts
Discussion Starter #20
I cant tell where the spot is coming from. Not sure. What I can tell you is that we have two cars both with starsheild and we drive them both the same, in the same areas and only one has this problem. Also we're not the type to leave bugs or tar sitting on something...and we wash religously and Ive kept up to date on compounds and cleaning on the board, we've tried it all to no avail.

The excellent news is that someone from starshield who reads this board saw my post and was able to contact me! AND, even better, his boss is in Louisville Kentucky this week for a trade show so he took my number and put us in contact! Good fortune. :)

So, we're going to hook up sometime tomorrow or wednesday and have a look!

I'll let you know.
 
1 - 20 of 28 Posts
Top