The Lotus Cars Community banner
1 - 5 of 5 Posts

·
Registered
Joined
·
795 Posts
Discussion Starter · #1 ·
Hi Guys,

After two and a half painful weeks of my Elise being out for a radiator swap at the dealer, I get the car back and I noticed that there's no air coming out of the air vents. I can hear the blower spinning, and there's a whole lot of air going somewhere, but not into the cabin. The dash/windshield/footwell air knob doesn't have any effect.

I can't go back to the dealer for a few days, so I was wondering if any of you can think of something obvious that they could have messed up. I'm guessing the ducting is disconnected from the fan somewhere, but I'm not familiar with the layout of ducting in the car's nose.

Thanks.
 

·
Registered
Joined
·
1,837 Posts
I have the same problem. I feel cold air drooling out of the vents, but there is no real airflow. I hope its covered by the warranty.

:shift:
 

·
Registered
Joined
·
6,981 Posts
Dang I thought this was going to be like the Dr.Drew hour. Blower problem brings something else to mind.
 

·
Registered
Joined
·
795 Posts
Discussion Starter · #4 ·
I have the same problem. I feel cold air drooling out of the vents, but there is no real airflow. I hope its covered by the warranty.

:shift:
I did some exploring and I found and fixed the problem. When you take off the front panels that cover the fuses and brake fluid reservoirs, feel around under that center divider that the panel pegs slide into. Right down the middle of the car, directly under that divider, is a rubber tube that's a smaller version of the flexible tubes found on clothes dryers. In my car, that tube slipped off a plastic base, which is where the blower output is. Once I slid the tube over the blower base, my climate control works fine.
 

·
Premium Member
Joined
·
4,565 Posts
I thought this was about a supercharger...
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top