The Lotus Cars Community banner
1 - 6 of 6 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
It's a 2007 Elise with the Katana and CharlieX's tune. S/C installed at about
1K miles. Car currently has almost 5K on it. Absolutely no problems until this past Friday. Drove the car to work....no problem. After work......car won't start.....it would just give the "tat-tat-tat" sound. Lights, horn & all electrical things were still working? Tried to jump it...... no go. So called AAA figuring that their batteries would put out more "juice". Still a no go. AAA guy recommended we push it and I catch it in gear. Now here is the weird part........... car turned over, but was hesitating and you could hear the misfiring, then the turn signals were going crazy, the tach and speedometer dials were going back and forth, dash lights flashing??? :eek: Then I removed my foot from the gas....it died! :shrug: Decided to have it towed to my home.........will be going to the dealer tomorrow! :( Any ideas??? Thanks!
 

·
Registered
Joined
·
6,960 Posts
I would always try the simplest thing first, a new battery, you had symptoms of that with the solinoid clicking, other lower current draw items will work. Low voltage in these cars do very strange things.
Michael
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #5 ·
Thanks all........was the battery! :clap: Funny but when I removed the existing Exide..... that green indicator light .....was in the "very green" level??..indicating that the battery was all charged up! :shrug: Any, went with the Optima Red 25 75 and all is good!
 

·
Registered
Joined
·
6,960 Posts
The "green" indicator is an integral hydrometer, which is indicative of the voltage. Voltage is only one part of the story, the other is capacity, or Amp Hours, which obviously your battery was deficient in. A defective battery can appear to be OK if only the voltage is measured without the optimistic surface charge being removed and no load test being done. Good choice on the Optima 75/25, I have one too.
Michael
Thanks all........was the battery! :clap: Funny but when I removed the existing Exide..... that green indicator light .....was in the "very green" level??..indicating that the battery was all charged up! :shrug: Any, went with the Optima Red 25 75 and all is good!
 
1 - 6 of 6 Posts
Top