The Lotus Cars Community banner
1 - 5 of 5 Posts

·
Registered
Joined
·
974 Posts
Discussion Starter · #1 ·
Had a weird issue today. Started the car up after it sat dormant for the week. I drove to Cars and Coffee and back without a problem. Dropped by a store on the way home. Then when I tried to start the car up, I heard an actuator like sound and then everything went dead. No stereo, warning lights, headlights, or anything. Whenever I hit the key fob, I'd get a soft "dying" chirp.

I couldn't start the car until I got my wife to swing by and jump start it. I drove the car less than a mile to get home. No problems starting the car two times in a row in the garage. A few hours later it started up fine again.

Any idea what the issue is? Did the alarm shut everything down? A bad battery? The Exide battery will be 3 years old in January so I have been thinking about getting a new one.
 

·
Registered
Joined
·
6,960 Posts
Replace the battery, http://www.lotustalk.com/forums/f129/battery-choices-information-64071/
Michael
Had a weird issue today. Started the car up after it sat dormant for the week. I drove to Cars and Coffee and back without a problem. Dropped by a store on the way home. Then when I tried to start the car up, I heard an actuator like sound and then everything went dead. No stereo, warning lights, headlights, or anything. Whenever I hit the key fob, I'd get a soft "dying" chirp.

I couldn't start the car until I got my wife to swing by and jump start it. I drove the car less than a mile to get home. No problems starting the car two times in a row in the garage. A few hours later it started up fine again.

Any idea what the issue is? Did the alarm shut everything down? A bad battery? The Exide battery will be 3 years old in January so I have been thinking about getting a new one.
 

·
Registered
Joined
·
974 Posts
Discussion Starter · #3 ·
I suspect that is the problem but I have gone through many batteries in other cars and I've never had a battery go out like this. Usually I get some indication that the battery is going bad like clicking noises when trying to start the car. Or usually I still have interior lights and other things still functioning.
 

·
Registered
Joined
·
974 Posts
Discussion Starter · #4 ·
I just hooked up my battery charger in case the battery is low on charge. In doing so, I discovered that the clamp to the negative terminal is loose. Hope that's the (only) problem.
 
1 - 5 of 5 Posts
Top