The Lotus Cars Community banner

1 - 10 of 10 Posts

·
Registered
Joined
·
593 Posts
Discussion Starter #1
I drove yesterday with AC on and windows up and heard some creaking/ clunking noises seemingly coming from the steering column. I could feel some feedback through the wheel that corresponded to the sounds. I'm thinking there may have been some damage to the front suspension when I spun out a week ago though I just noticed this yesterday. I'm thinking I should take my car up to Fox Valley. As much as I would like to just start disassembling the car to work on it Id probably do more harm than good. Any suggestions to diagnose the problem?


Sent from my iPad using Autoguide
 

·
shay2nak
Joined
·
25,068 Posts
bunch of people had/have this. You'll find your answers if you search, but i think yours might be from the shock mounting bracket being loose.
 

·
Registered
Joined
·
593 Posts
Discussion Starter #3
TJ found out what it was, though I'm tired and lazy now and don't feel like digging through emails. The Sector111 suspension refresh kit is going to take care of it and then some! I'll clarify tomorrow what it exactly was.


Sent from my iPad using Autoguide
 

·
Registered
Joined
·
2,771 Posts
It was worn control arms an some bushings that needed replaced.
  • Are you saying they replaced control arms, not just bushings?
  • Which bushings (I'm guessing all the wishbone bushings)?
  • Which control arms? (upper wishbone, lower wishbone, steering arm, steering track rod end)
  • Where was the control arm worn (if you know)?

I ask because I also have a problem, it is temperature dependent, and doesn't seem like the rack. I am guessing the wishbone bushings.
 

·
Registered
Joined
·
1,314 Posts
just to clarify, the control arm bushings were worn out and when that happens the begin to push out of the control arm and the edge of the arm can contact the tub, and subframe giving a clunk and a creak. I also found the hhardware holding everything in place had become lower than torque. meaning, not loose, but not to spec.

We went ahead with a full suspension refresh kit from sector111. the OP lives far from me, so we just did it all to give peace of mind that all will be good for the long run.

T.J.
 

·
Registered
Joined
·
1,314 Posts
Chris, also check the (2) 13mm head bolts on both sides that hold the front upper strut mount in place. I have seen these come loose and give a bit of a clunk.
 

·
Registered
Joined
·
2,771 Posts
just to clarify, the control arm bushings ....
Just to clarify, when you say control arm, you mean wishbones, right? Lotus doesn't use the term "control arm".


Chris, also check the (2) 13mm head bolts on both sides that hold the front upper strut mount in place. I have seen these come loose and give a bit of a clunk.
That one I did a long time ago. I started the original thread on it.
http://www.lotustalk.com/forums/f91/little-clunks-steering-not-steering-rack-thread-78381/
 

·
Registered
Joined
·
1,848 Posts
With my exige, it's the inner tie rod, passenger side on the rack. If you pull the wheel and wiggle the upright, you'll get clunkity clunk that transmits right through the chassis. Pull the wheels and see if you can duplicate it - here's my version:

 
1 - 10 of 10 Posts
Top