The Lotus Cars Community banner
1 - 11 of 11 Posts

·
Registered
Joined
·
120 Posts
Discussion Starter · #1 · (Edited)
Title says it all. I have a code in pending P0016 (Crankshaft Position Camshaft Position Correlation (Bank 1 Sensor A)) and it has turned into a real code a few times. My dyno is also looking very wierd since the code has been thrown. Now i did read what the code stood for in our engines. I am trying to figure out if I have a bad sensor and if so what sensor. Any help would be great.
 

Attachments

·
Registered
Joined
·
1,966 Posts
You may want to shrink that picture :crazyeyes
 

·
Registered
Joined
·
682 Posts
I'm not sure if this helps, but if you turn the dyno graph sideways, it looks like boobs.

:shrug:
 

·
Registered
Joined
·
1,416 Posts
I have a code in pending P0016 (Crankshaft Position Camshaft Position Correlation (Bank 1 Sensor A)) and it has turned into a real code a few times. My dyno is also looking very wierd since the code has been thrown. Now i did read what the code stood for in our engines. I am trying to figure out if I have a bad sensor and if so what sensor.
I can't find a listing or definition for a P0016 Code in my manual or on OBD-Codes.com. :shrug:

I do have a pic of all the engine sensor locations, which may help. The Crankshaft sensor (#8 in the diagram) is located at the bottom of the engine, get at it from underneath.

Good Luck!

Regards,
Wayne
 

Attachments

·
Registered
Joined
·
120 Posts
Discussion Starter · #8 ·
I can't find a listing or definition for a P0016 Code in my manual or on OBD-Codes.com. :shrug:

I do have a pic of all the engine sensor locations, which may help. The Crankshaft sensor (#8 in the diagram) is located at the bottom of the engine, get at it from underneath.

Good Luck!

Regards,
Wayne
Wayne,
Thanks for the chart. I am leaning towards replacing the sensor, since it believe it is easy to get to. Do you know the toyota part#.
 

·
Registered
Joined
·
1,416 Posts
Do you know the toyota part#.
I believe the part number is W0133-1786732. It's for a 2ZZ engine, Matrix, 1.8L. Costs $100 at a bunch of on-line stores.

Regards,
Wayne
 

·
Registered
Joined
·
10,000 Posts
hard to tell conclusively without the whole dyno to get an idea of the scale of the dip, but its saying your cam offset is incorrect, which would tie up with a decent loss of power. the sensor reads the position, it doesn't set it.
 

·
Registered
Joined
·
120 Posts
Discussion Starter · #11 · (Edited)
hard to tell conclusively without the whole dyno to get an idea of the scale of the dip, but its saying your cam offset is incorrect, which would tie up with a decent loss of power. the sensor reads the position, it doesn't set it.
Thanks Charlie, I dont' have the whole pic right now. It is a 30hp drop when hitting the second cam. Car runs great except for that lol and the code. I may try to change crank sensor because P0016 comes up in pending right when the car turns over. I read this paper that has me leaning this way. http://www.ncttora.com/fsm/04-06-Tu...ypdf/06rmsrc/06tundra/di/eg2uzfe/cip0016p.pdf But my RPM gauge is working correctly, so I would think it isn't the Crank sensor. Oh the car runs very smooth so i don't think it is not aligned.
 
1 - 11 of 11 Posts
Top