The Lotus Cars Community banner

1 - 20 of 30 Posts

·
Registered
Joined
·
1,581 Posts
Discussion Starter #1
I've noticed that the shift light flickers randomly. It's just a slight flicker...meaning when the shift light really comes on, it's bright. But the flickering is so brief that it does illuminate very much.

Any ideas of what this could be?

TIA
 

·
Registered
Joined
·
549 Posts
ekological said:
I've noticed that the shift light flickers randomly. It's just a slight flicker...meaning when the shift light really comes on, it's bright. But the flickering is so brief that it does illuminate very much.

Any ideas of what this could be?

TIA
One on OUR Elise does not flicker...but remember this shift light is also the alarm on indication light...maybe something to do with that...:confused:
 

·
Registered
Joined
·
9,150 Posts
Mine flickers once in a blue moon if the revs are too low, or if I have REALLY been pushing it sometimes. 99.5% of the time it does NOT flicker, so me no worry.
 

·
Registered
Joined
·
140 Posts
Mine flickers when the idle is super low: as in while idlen' blip the throttle. . . .when the revs drop down the first time, my light flickers). I don't do it much, because of the super light flywheel, it will cut off, but I've notice that is when mine flickered. As you let the car "learn" the idle, it stops.
 

·
Banned
Joined
·
6,941 Posts
The manual says to quickly shift when the shift light comes on. Sounds like it might go off a hair early so that revs continue to rise during your reaction time. Before the rev limiter kicks in, that is.
 

·
Registered
Joined
·
1,581 Posts
Discussion Starter #8
Well, they say for maximum acceleration, you're supposed to shift as soon as the light comes on. I don't think that's good, though since if you shift when it first comes on, you'll fall off the cams on the next gear.
 

·
Banned
Joined
·
6,941 Posts
>>>Well, they say for maximum acceleration, you're supposed to shift as soon as the light comes on. I don't think that's good, though since if you shift when it first comes on, you'll fall off the cams on the next gear<<<

Well the momentary extra 500 revs are supposed to help with staying on lift. And once you're there, it stays on if Rs are above 5800 RPMs. (Lift hits at about 6200 going up through the revs)

When exactly does the light go on compared to the actual rev limiter? (I've only hit lift briefly a few times and only to about 7400 so far - I'm at about 850 miles now, past the 600 where they say you can up the Rs.)
 

·
Registered
Joined
·
9,150 Posts
My shift light comes on at 8000 RPM. The rev limiter is at 8500 or 8600, i can't be sure because I'm usually blowing by someone and my eyes are not on the tach so much...
 

·
Registered
Joined
·
79 Posts
I took my car in for the 1000 miles tune up. cost me 250.
My RPM light also flickles during idle. the service guy called Lotus USA and they said there are a few cars with that problems. they don't know why.

I had rev the engine too high before optimal temp once. The engine power was cut off. There was also another time when I took the engine to 8000 to 8500 rpm. the rpm light went on and I up shifted within 2-3 sec. I hope the above did not cause the problem.

Did anybody fix the flickle problem?

bert
 

·
Registered
Joined
·
140 Posts
As I mentioned in my post above, it sorted itself out. And just to clarify, we are not talking about the shift/alarm "light showing full on", we are talking about a very light flicker.
 

·
Registered
Joined
·
9,150 Posts
Mine hasn't done it in a while now (not in the last 2K miles). I'm up to 4K already----yikes!
 

·
Registered
Joined
·
6,293 Posts
I have not noticed mine doing that, only 305 miles...
 

·
Registered
Joined
·
3,914 Posts
mine "flickers" slightly at times. it does so at idle and even light throttle, but only occasionally.
I'm just under 500 miles. I'll just wait until my 1st service and mention it to the service manager.
 

·
Registered
Joined
·
1,581 Posts
Discussion Starter #17
After my first service, the tech noticed the battery terminals (not the ones directly attached to the battery) were loose. He said that Lotus ships the car this way and that some dealers forget to tighten them. After the connection was tightened, the light didn't flicker any longer.

FWIW
 

·
Registered
Joined
·
3,914 Posts
ekological said:
After my first service, the tech noticed the battery terminals (not the ones directly attached to the battery) were loose. He said that Lotus ships the car this way and that some dealers forget to tighten them. After the connection was tightened, the light didn't flicker any longer.

FWIW
ok, if not the one directly attached to the battery, then which ones? I'll take a look, thanks...
 

·
Registered
Joined
·
2,343 Posts
mine flickered some ... then more ... and within a month it would flicker like mad. Was VERY annoying at night.

It was obviously not anything to do with the alarm or shift indicator or the rev limiter. You'd cruise the highway at 60mph in 5th and the thing would just go nuts in a '5 to 10 flickers per second' sort of way. About half of them wouldn't get to full brightness.

Then I got my car back from first service and it's never done it again! Good luck.

-doma
 

·
Registered
Joined
·
486 Posts
I've NEVER seen my shift light illuminate or blink at all...except when having to disarm the alarm and start the car. Are we talking about the same light??
 
1 - 20 of 30 Posts
Top